summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-02 21:49:48 -0600
committerLuis Martinez2022-01-02 21:49:48 -0600
commit8fccae7ec4540f885d42c8bf23e07d2fe54bca1c (patch)
tree2de223cc3ef44efaaf7e70b7e4ba02bf503f5538
downloadaur-8fccae7ec4540f885d42c8bf23e07d2fe54bca1c.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--nordic.install9
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f1a5641e8a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-nordic-git
+ pkgdesc = Nord-esque colorscheme for Neovim
+ pkgver = r141.c348fba
+ pkgrel = 1
+ url = https://github.com/andersevenrud/nordic.nvim
+ install = nordic.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim
+ provides = neovim-nordic
+ conflicts = neovim-nordic
+ source = neovim-nordic-git::git+https://github.com/andersevenrud/nordic.nvim
+ md5sums = SKIP
+
+pkgname = neovim-nordic-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f92a87275de3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-nordic-git
+pkgver=r141.c348fba
+pkgrel=1
+pkgdesc="Nord-esque colorscheme for Neovim"
+arch=('any')
+url="https://github.com/andersevenrud/nordic.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=nordic.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find colors lua -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/nordic.install b/nordic.install
new file mode 100644
index 000000000000..cc25eece3dea
--- /dev/null
+++ b/nordic.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-nordic-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}