summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-11-02 19:39:36 -0500
committerLuis Martinez2021-11-02 19:39:36 -0500
commit1e8c70c0d64d1f014dcc92c9c591de39a73ab4b3 (patch)
tree6841780904515d467e9b8f110eabe9ffa2b1fcd7
parent9279f9e370a44ab76966c24df6692f1964595b50 (diff)
downloadaur-1e8c70c0d64d1f014dcc92c9c591de39a73ab4b3.tar.gz
update to 1.10.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df4923a71293..1c5d829d4372 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = neovim-notify
pkgdesc = Notification manager for Neovim
- pkgver = 1.8.2
+ pkgver = 1.10.0
pkgrel = 1
url = https://github.com/rcarriga/nvim-notify
install = notify.install
arch = any
groups = neovim-plugin
- license = unknown
+ license = MIT
+ checkdepends = neovim-plenary
depends = neovim
- source = neovim-notify-1.8.2.tar.gz::https://github.com/rcarriga/nvim-notify/archive/v1.8.2.tar.gz
- sha256sums = 37d460afeaa709004185a94ab5bb25f084425028df1447d40b49bdec4fd582d1
+ optdepends = neovim-telescope
+ source = neovim-notify-1.10.0.tar.gz::https://github.com/rcarriga/nvim-notify/archive/v1.10.0.tar.gz
+ sha256sums = 5a68d9140f9cdd8cf2e837685d2c168529fe656287908dee1b48e827af26c2ea
pkgname = neovim-notify
diff --git a/PKGBUILD b/PKGBUILD
index c07af70b4d83..11cace01e487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,28 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=neovim-notify
-pkgver=1.8.2
+pkgver=1.10.0
pkgrel=1
pkgdesc="Notification manager for Neovim"
arch=('any')
url="https://github.com/rcarriga/nvim-notify"
-license=('unknown')
+license=('MIT')
groups=('neovim-plugin')
depends=('neovim')
-# optdepends=('neovim-telescope') ## not yet
+optdepends=('neovim-telescope')
+checkdepends=('neovim-plenary')
install=notify.install
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('37d460afeaa709004185a94ab5bb25f084425028df1447d40b49bdec4fd582d1')
+sha256sums=('5a68d9140f9cdd8cf2e837685d2c168529fe656287908dee1b48e827af26c2ea')
+
+check() {
+ cd "nvim-notify-$pkgver"
+ ./scripts/test
+}
package() {
cd "nvim-notify-$pkgver"
- find lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ find doc lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}