summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-09 20:40:01 -0500
committerLuis Martinez2021-10-09 20:43:18 -0500
commit9279f9e370a44ab76966c24df6692f1964595b50 (patch)
treed81e3db30e8fb67e70f3c28da7bfb0f2f3254213
downloadaur-9279f9e370a44ab76966c24df6692f1964595b50.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
-rw-r--r--notify.install9
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df4923a71293
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-notify
+ pkgdesc = Notification manager for Neovim
+ pkgver = 1.8.2
+ pkgrel = 1
+ url = https://github.com/rcarriga/nvim-notify
+ install = notify.install
+ arch = any
+ groups = neovim-plugin
+ license = unknown
+ depends = neovim
+ source = neovim-notify-1.8.2.tar.gz::https://github.com/rcarriga/nvim-notify/archive/v1.8.2.tar.gz
+ sha256sums = 37d460afeaa709004185a94ab5bb25f084425028df1447d40b49bdec4fd582d1
+
+pkgname = neovim-notify
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c07af70b4d83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-notify
+pkgver=1.8.2
+pkgrel=1
+pkgdesc="Notification manager for Neovim"
+arch=('any')
+url="https://github.com/rcarriga/nvim-notify"
+license=('unknown')
+groups=('neovim-plugin')
+depends=('neovim')
+# optdepends=('neovim-telescope') ## not yet
+install=notify.install
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('37d460afeaa709004185a94ab5bb25f084425028df1447d40b49bdec4fd582d1')
+
+package() {
+ cd "nvim-notify-$pkgver"
+ find lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/notify.install b/notify.install
new file mode 100644
index 000000000000..87c16fbb5dbb
--- /dev/null
+++ b/notify.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-notify/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}