summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-27 22:34:18 -0500
committerLuis Martinez2021-05-28 02:09:21 -0500
commit78c08cc8a61e6937e56bacba99d696b5d421dc21 (patch)
tree48566d625e1eb6ecf7128e24220df924acad3d65
downloadaur-78c08cc8a61e6937e56bacba99d696b5d421dc21.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--neovim-plenary-git.install16
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b4c87b24252
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-plenary-git
+ pkgdesc = A Lua library for Neovim plugins
+ pkgver = r150.3f99330
+ pkgrel = 1
+ url = https://github.com/nvim-lua/plenary.nvim
+ install = neovim-plenary-git.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim
+ provides = neovim-plenary
+ conflicts = neovim-plenary
+ source = neovim-plenary-git::git+https://github.com/nvim-lua/plenary.nvim
+ sha256sums = SKIP
+
+pkgname = neovim-plenary-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e927646e6d00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=neovim-plenary-git
+pkgver=r150.3f99330
+pkgrel=1
+pkgdesc="A Lua library for Neovim plugins"
+arch=('any')
+url="https://github.com/nvim-lua/plenary.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install="$pkgname.install"
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find data lua plugin \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/neovim-plenary-git.install b/neovim-plenary-git.install
new file mode 100644
index 000000000000..658f2ae0126c
--- /dev/null
+++ b/neovim-plenary-git.install
@@ -0,0 +1,16 @@
+post_install() {
+ printf "
+ :: This plugin must be activated through your init file.
+ :: You can do so with either of the following:
+
+ init.vim: lua 'require('gitsigns').setup()'
+
+ init.lua: require('gitsigns').setup()
+ \n"
+}
+
+post_remove() {
+ printf "
+ :: Remember to remove your setup from your init files!
+ \n"
+}