summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2015-08-05 21:46:07 -0400
committerAaron Abbott2015-08-05 21:46:07 -0400
commit098b2b442d5809882ecd9d52688116f88fc9a270 (patch)
tree6fcf2c47c3450019629a9185ee83a496feffa72b
downloadaur-098b2b442d5809882ecd9d52688116f88fc9a270.tar.gz
Initial commit and release 1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD55
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60055ed5c20e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neovim-qt-git
+ pkgdesc = A Qt gui for Neovim (Neovim RPC and GUI using Qt5).
+ pkgver = r219.49a61e0
+ pkgrel = 1
+ url = https://github.com/equalsraf/neovim-qt
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = cmake
+ depends = neovim
+ depends = qt5-base
+ depends = msgpack-c
+ conflicts = neovim-qt
+ source = neovim-qt-git::git+https://github.com/equalsraf/neovim-qt.git
+ md5sums = SKIP
+
+pkgname = neovim-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef66da9a6924
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Aaron Abbott <aabmass at gmail dot com>
+pkgname=neovim-qt-git
+pkgver=r219.49a61e0
+pkgrel=1
+pkgdesc="A Qt gui for Neovim (Neovim RPC and GUI using Qt5)."
+arch=('i686' 'x86_64')
+url="https://github.com/equalsraf/neovim-qt"
+license=('custom')
+groups=()
+# not sure which qt5 dependency to add
+depends=('neovim' 'qt5-base' 'msgpack-c')
+makedepends=('git' 'cmake')
+provides=()
+conflicts=('neovim-qt')
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+${url}.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ mkdir -p "${pkgname}/build"
+ cd "${pkgname}/build"
+
+ cmake -G 'Unix Makefiles' -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_SYSTEM_MSGPACK=ON -DCMAKE_INSTALL_PREFIX=/usr ..
+
+ make
+}
+
+package() {
+ cd "${pkgname}/build"
+
+ # cmake isn't configured to install anything, do it on our own
+ install -D -m755 bin/nvim-qt "${pkgdir}/usr/bin/nvim-qt"
+ install -D -m644 lib/libneovim-qt.a "${pkgdir}/usr/lib/libneovim-qt.a"
+
+ # install the custom license
+ install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}