summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2017-03-17 00:26:44 -0400
committerAaron Abbott2017-03-17 00:26:44 -0400
commit49d12da173d721259d121baa5cad0bb38683a894 (patch)
treea272916308f75b9a532bdf0613a808c900473c15
parent060001612d347de57fbcb0eb8ca1c72c9c92e54e (diff)
downloadaur-49d12da173d721259d121baa5cad0bb38683a894.tar.gz
Fixed issue with overwriting nvim help tag index
@Stunts pointed out that neovim and neovim-qt-git claimed to own /usr/share/nvim/runtime/doc/tags, causing an installation conflicting files errors. Additionally, this would overwrite the neovim help tags!! Fixed the scripts to only install the .vim plugin and .txt doc files from neovim-qt-git and then allow the postinstall script to update the neovim index
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rw-r--r--neovim-qt-git.install3
3 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26c0b8ac5fe1..d7c362b6ab2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Nov 9 02:04:50 UTC 2016
+# Fri Mar 17 04:26:24 UTC 2017
pkgbase = neovim-qt-git
pkgdesc = A Qt gui for Neovim (Neovim RPC and GUI using Qt5).
- pkgver = v0.2.4.r0.g4015d8c
+ pkgver = v0.2.4.r17.g7b4bbbc
pkgrel = 1
url = https://github.com/equalsraf/neovim-qt
install = neovim-qt-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 56b86f25cc61..b0434ee88c57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Aaron Abbott <aabmass at gmail dot com>
pkgname=neovim-qt-git
-pkgver=v0.2.4.r0.g4015d8c
+pkgver=v0.2.4.r17.g7b4bbbc
pkgrel=1
pkgdesc="A Qt gui for Neovim (Neovim RPC and GUI using Qt5)."
arch=('i686' 'x86_64')
@@ -42,16 +42,22 @@ package() {
cd "${pkgname}/build"
## cmake isn't configured to install anything, do it on our own
-
# install the binaries and libs
install -D -m755 bin/nvim-qt "${pkgdir}/usr/bin/nvim-qt"
install -D -m644 lib/libneovim-qt.a "${pkgdir}/usr/lib/libneovim-qt.a"
- # install any plugins packaged with nvim-qt
- mkdir -p "${pkgdir}/usr/share/nvim"
- cp -R ../src/gui/runtime "${pkgdir}/usr/share/nvim"
- find "${pkgdir}/usr/share/nvim/runtime" -type f -exec chmod 644 {} \;
+ ## install any plugins packaged with nvim-qt
+ # need to cd so find outputs regular paths
+ cd ../src/gui/runtime
+
+ # find .vim and .txt files and install them into pkgdir
+ find . -type f -regex ".*\.\(vim\|txt\)" \
+ -exec install -D -m644 {} ${pkgdir}/usr/share/nvim/runtime/{} \;
+
+ # go back to the previous dir
+ cd -
+ ## other files to install
# install the custom license
install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
diff --git a/neovim-qt-git.install b/neovim-qt-git.install
index 58cccc785a99..46c1bf1f0bd2 100644
--- a/neovim-qt-git.install
+++ b/neovim-qt-git.install
@@ -1,5 +1,8 @@
post_install() {
echo -n ":: Updating nvim help tags..."
+
+ # updates the nvim help tags index to include the doc files that were
+ # just installed with neovim-qt-git, e.g. nvim_gui_shim.txt
/usr/bin/nvim --noplugin -u NONE -U NONE \
--cmd ":helptags /usr/share/nvim/runtime/doc" --cmd ":q" > /dev/null 2>&1
echo "done."