summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2016-05-04 17:26:30 -0400
committerAaron Abbott2016-05-04 17:26:30 -0400
commitd7b9c8635b94c69a9c0d3ee4b33476bd56a2cf88 (patch)
tree64e8777808dfc2df3bcd1ced74a9612a8811974b
parentfa8d77915369ff699680053b54a7bcebdc983f8b (diff)
downloadaur-d7b9c8635b94c69a9c0d3ee4b33476bd56a2cf88.tar.gz
Updated to install any plugins shipped
Install any plugins in src/gui/runtime/ to /usr/share/nvim/runtime. Specifically these: https://github.com/equalsraf/neovim-qt/tree/master/src/gui/runtime. Also required a .install file be made to update the helptags for neovim so that any docs installed are accessible.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
-rw-r--r--neovim-qt-git.install14
3 files changed, 25 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b897665d1a58..0b8aecd5b094 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Thu Apr 28 19:29:33 UTC 2016
+# Wed May 4 21:26:03 UTC 2016
pkgbase = neovim-qt-git
pkgdesc = A Qt gui for Neovim (Neovim RPC and GUI using Qt5).
pkgver = r325.cec1120
pkgrel = 1
url = https://github.com/equalsraf/neovim-qt
+ install = neovim-qt-git.install
arch = i686
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index d0e45d1aae64..4e2babc12452 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ conflicts=('neovim-qt')
replaces=()
backup=()
options=()
-install=
+install=neovim-qt-git.install
source=("${pkgname}::git+${url}.git")
noextract=()
md5sums=('SKIP')
@@ -41,10 +41,17 @@ build() {
package() {
cd "${pkgname}/build"
- # cmake isn't configured to install anything, do it on our own
+ ## cmake isn't configured to install anything, do it on our own
+
+ # install the binaries and libs
install -D -m755 bin/nvim-qt "${pkgdir}/usr/bin/nvim-qt"
install -D -m644 lib/libneovim-qt.a "${pkgdir}/usr/lib/libneovim-qt.a"
+ # install any plugins packaged with nvim-qt
+ mkdir -p "${pkgdir}/usr/share/nvim"
+ cp -R ../src/gui/runtime "${pkgdir}/usr/share/nvim"
+ find "${pkgdir}/usr/share/nvim/runtime" -type f -exec chmod 644 {} \;
+
# install the custom license
install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
diff --git a/neovim-qt-git.install b/neovim-qt-git.install
new file mode 100644
index 000000000000..58cccc785a99
--- /dev/null
+++ b/neovim-qt-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n ":: Updating nvim help tags..."
+ /usr/bin/nvim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/nvim/runtime/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}