summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2016-04-28 15:29:57 -0400
committerAaron Abbott2016-04-28 15:29:57 -0400
commitfa8d77915369ff699680053b54a7bcebdc983f8b (patch)
tree4d9c07271e03186ff36c2ebe4cdf9188b0ef4a84
parent7cd54b1c035d1f54134558365506a69ec01b8737 (diff)
downloadaur-fa8d77915369ff699680053b54a7bcebdc983f8b.tar.gz
Install the .desktop file and neovim icon
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e6db42b3fbb..b897665d1a58 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Apr 28 19:29:33 UTC 2016
pkgbase = neovim-qt-git
pkgdesc = A Qt gui for Neovim (Neovim RPC and GUI using Qt5).
- pkgver = r219.49a61e0
- pkgrel = 2
+ pkgver = r325.cec1120
+ pkgrel = 1
url = https://github.com/equalsraf/neovim-qt
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5bf58e6c08eb..d0e45d1aae64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aaron Abbott <aabmass at gmail dot com>
pkgname=neovim-qt-git
-pkgver=r219.49a61e0
-pkgrel=2
+pkgver=r325.cec1120
+pkgrel=1
pkgdesc="A Qt gui for Neovim (Neovim RPC and GUI using Qt5)."
arch=('i686' 'x86_64')
url="https://github.com/equalsraf/neovim-qt"
@@ -35,7 +35,7 @@ build() {
cmake -G 'Unix Makefiles' -DCMAKE_BUILD_TYPE=Release \
-DUSE_SYSTEM_MSGPACK=ON -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ make ${MAKEFLAGS}
}
package() {
@@ -47,4 +47,8 @@ package() {
# install the custom license
install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # install desktop files
+ install -D -m644 ../src/gui/nvim-qt.desktop "${pkgdir}"/usr/share/applications/nvim-qt.desktop
+ install -D -m644 ../third-party/neovim.png "${pkgdir}"/usr/share/pixmaps/nvim-qt.png
}