summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaochen Tong2018-10-08 21:24:48 +0200
committerHaochen Tong2018-10-08 21:24:48 +0200
commitd0cc7de12ca3ac70b49e89a369d8586e38b47fb5 (patch)
tree39b6bcc512e17e272832107a5cb4bcd440fb9f18
parent80da61d8454c994d4b54a2b5874bfe767f7086ba (diff)
downloadaur-d0cc7de12ca3ac70b49e89a369d8586e38b47fb5.tar.gz
upgpkg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84dc01f5a50e..78eceff2c37f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 12 10:16:24 UTC 2018
+# Mon Oct 8 19:24:36 UTC 2018
pkgbase = neovim-remote
pkgdesc = Support --remote and friends for Neovim
- pkgver = 2.0.10
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/mhinz/neovim-remote
arch = any
@@ -11,8 +11,8 @@ pkgbase = neovim-remote
makedepends = python-setuptools
depends = python-neovim
depends = python-psutil
- source = git+https://github.com/mhinz/neovim-remote.git#tag=v2.0.10
- sha1sums = SKIP
+ source = https://github.com/mhinz/neovim-remote/archive/v2.1.0.tar.gz
+ sha256sums = 27d946a07df4aec02c10be71ce3b3ace7bfd52f0456afce44a537ad6e10a881d
pkgname = neovim-remote
diff --git a/PKGBUILD b/PKGBUILD
index 1b644a7fd839..61f2dc711d9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hexchain Tong <i at hexchain dot org>
pkgname=neovim-remote
-pkgver=2.0.10
+pkgver=2.1.0
pkgrel=1
pkgdesc="Support --remote and friends for Neovim"
arch=(any)
@@ -8,12 +8,12 @@ url="https://github.com/mhinz/neovim-remote"
license=('MIT')
depends=('python-neovim' 'python-psutil')
makedepends=('git' 'python-setuptools')
-source=("git+https://github.com/mhinz/neovim-remote.git#tag=v${pkgver}")
-sha1sums=('SKIP')
+source=("https://github.com/mhinz/neovim-remote/archive/v$pkgver.tar.gz")
+sha256sums=('27d946a07df4aec02c10be71ce3b3ace7bfd52f0456afce44a537ad6e10a881d')
package() {
- cd "$srcdir/$pkgname"
- python setup.py install --root="$pkgdir/"
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install -O1 --root="$pkgdir/"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}