summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-12-09 11:51:36 -0600
committerLuis Martinez2021-12-09 11:51:36 -0600
commit94784e5a60cf905da184bdee099af07218e075f1 (patch)
tree39c17f97db6df4c643b7d3398caa7a5362b5d114
downloadaur-94784e5a60cf905da184bdee099af07218e075f1.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--stabilize.install9
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..377950f59774
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-stabilize-git
+ pkgdesc = Stabilizes buffer content on window events
+ pkgver = r36.191d102
+ pkgrel = 1
+ url = https://github.com/luukvbaal/stabilize.nvim
+ install = stabilize.install
+ arch = any
+ groups = neovim-plugins
+ license = BSD
+ makedepends = git
+ depends = neovim
+ provides = neovim-stabilize
+ conflicts = neovim-stabilize
+ source = neovim-stabilize-git::git+https://github.com/luukvbaal/stabilize.nvim?signed
+ validpgpkeys = 521E78F69DC400BA56D4C424E7D1BC845D39FA83
+ md5sums = SKIP
+
+pkgname = neovim-stabilize-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69249448ca88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-stabilize-git
+pkgver=r36.191d102
+pkgrel=1
+pkgdesc="Stabilizes buffer content on window events"
+arch=('any')
+url="https://github.com/luukvbaal/stabilize.nvim"
+license=('BSD')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=stabilize.install
+source=("$pkgname::git+$url?signed")
+md5sums=('SKIP')
+validpgpkeys=('521E78F69DC400BA56D4C424E7D1BC845D39FA83') ## Luuk van Baal
+## curl https://github.com/luukvbaal.gpg | gpg --import
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/stabilize.install b/stabilize.install
new file mode 100644
index 000000000000..31593e5ecbfa
--- /dev/null
+++ b/stabilize.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-stabilize-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}