summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-19 09:56:49 -0500
committerLuis Martinez2021-10-19 09:56:49 -0500
commitfab258a1b17a7925780c18da1116fb4ee6d1277d (patch)
treef4b28b3b24573fe7b3f89f90ca3e84bc67f50d88
downloadaur-fab258a1b17a7925780c18da1116fb4ee6d1277d.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
-rw-r--r--staline.install9
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6dde909bbfcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-staline-git
+ pkgdesc = Modern lightweight statusline and bufferline
+ pkgver = r229.ad1bef9
+ pkgrel = 1
+ url = https://github.com/tamton-aquib/staline.nvim
+ install = staline.install
+ arch = any
+ groups = neovim-plugin
+ license = MIT
+ makedepends = git
+ depends = neovim>=0.5.0
+ provides = neovim-staline
+ conflicts = neovim-staline
+ source = neovim-staline-git::git+https://github.com/tamton-aquib/staline.nvim
+ md5sums = SKIP
+
+pkgname = neovim-staline-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab192674cdcc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-staline-git
+pkgver=r229.ad1bef9
+pkgrel=1
+pkgdesc="Modern lightweight statusline and bufferline"
+arch=('any')
+url="https://github.com/tamton-aquib/staline.nvim"
+license=('MIT')
+groups=('neovim-plugin')
+depends=('neovim>=0.5.0')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=staline.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/staline.install b/staline.install
new file mode 100644
index 000000000000..5c21f12ca477
--- /dev/null
+++ b/staline.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-staline-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}