summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Bremmer2016-10-13 17:35:46 +0200
committerJoost Bremmer2016-10-13 17:35:46 +0200
commita55a9b7baf28e670669b15e5505df1eaf4203099 (patch)
tree7f5bcfab22b385b352172ee26dfad1b2589ba750
downloadaur-a55a9b7baf28e670669b15e5505df1eaf4203099.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore19
-rw-r--r--LICENSE32
-rw-r--r--PKGBUILD29
-rw-r--r--nvim-doc.install14
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74eb95bd090c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-supertab
+ pkgdesc = A Neovim plugin that allows you to use the tab key to do all insert completion.
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://github.com/ervandew/supertab
+ install = nvim-doc.install
+ arch = any
+ groups = neovim-plugins
+ license = BSD
+ depends = neovim
+ source = https://github.com/ervandew/supertab/archive/2.1.tar.gz
+ source = LICENSE
+ md5sums = 8c9fd74e228521f64221b91e1a54abfe
+ md5sums = a232f3fa724b2e52e1678adcc84f67bb
+
+pkgname = neovim-supertab
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7123c0a23024
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# package src/pkg archives, downloaded sources
+*.tar*
+*.tgz
+*.zip
+
+# signed sources
+*.asc
+*.sig
+
+# subfolders, e.g. source or built package trees, vcs
+*/**/
+!neovim-plugins/*
+# backup files
+*~
+*.bak
+pkg
+src
+*xpi
+*tar*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a3d5b7c2d5da
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,32 @@
+Copyright (c) 2002 - 2010
+All rights reserved.
+
+Redistribution and use of this software in source and binary forms, with
+or without modification, are permitted provided that the following
+conditions are met:
+
+* Redistributions of source code must retain the above
+ copyright notice, this list of conditions and the
+ following disclaimer.
+
+* Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the
+ following disclaimer in the documentation and/or other
+ materials provided with the distribution.
+
+* Neither the name of Gergely Kontra or Eric Van Dewoestine nor the names
+of its contributors may be used to endorse or promote products derived
+from this software without specific prior written permission of Gergely
+Kontra or Eric Van Dewoestine.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
+IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6685b108c7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Joost Bremmer <toost.b@gmail.com>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Kaiting Chen <kaitocracy@gmail.com>
+# Contributor: Aaron Schaefer <aaron@elasticdog.com>
+
+pkgname=neovim-supertab
+pkgver=2.1
+pkgrel=1
+pkgdesc='A Neovim plugin that allows you to use the tab key to do all insert completion.'
+arch=('any')
+url='https://github.com/ervandew/supertab'
+license=('BSD')
+depends=('neovim')
+groups=('neovim-plugins')
+install=nvim-doc.install
+source=("https://github.com/ervandew/supertab/archive/$pkgver.tar.gz"
+ 'LICENSE')
+md5sums=('8c9fd74e228521f64221b91e1a54abfe'
+ 'a232f3fa724b2e52e1678adcc84f67bb')
+
+package() {
+ cd "$srcdir/supertab-$pkgver"
+
+ installpath="$pkgdir/usr/share/nvim/runtime"
+
+ install -Dm0644 doc/supertab.txt "$installpath/doc/supertab.txt"
+ install -Dm0644 plugin/supertab.vim "$installpath/plugin/supertab.vim"
+ install -Dm0644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/nvim-doc.install b/nvim-doc.install
new file mode 100644
index 000000000000..79795d84c37b
--- /dev/null
+++ b/nvim-doc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating neovim help tags..."
+ /usr/bin/nvim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/nvim/runtime/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}