summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShane Stone2019-04-19 21:53:28 -0700
committerShane Stone2019-04-19 21:53:28 -0700
commit0fd7acd9607143806603dd2c13933fabe1aded24 (patch)
tree3686cc0c5724bfdb44cdb68cfdc3fb38bc3727f4
downloadaur-0fd7acd9607143806603dd2c13933fabe1aded24.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f64ac82bfab8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-surround-opt-git
+ pkgdesc = Provides mappings to easily delete, change, and add paired "surroundings."
+ pkgver = 109.5970688
+ pkgrel = 1
+ url = https://github.com/tpope/vim-surround
+ arch = any
+ license = custom:vim
+ makedepends = git
+ depends = neovim
+ source = git+https://github.com/tpope/vim-surround.git
+ sha256sums = SKIP
+
+pkgname = neovim-surround-opt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b82ccf3da3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=neovim-surround-opt-git
+pkgver=109.5970688
+_pkgname=surround
+pkgrel=1
+pkgdesc='Provides mappings to easily delete, change, and add paired "surroundings."'
+arch=('any')
+url="https://github.com/tpope/vim-${_pkgname}"
+license=('custom:vim')
+depends=('neovim')
+makedepends=('git')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+
+ cd "${srcdir}/vim-${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/vim-${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rvt "${pkgdir}/${_installpath}" doc plugin
+
+}