summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Bremmer2024-03-10 03:34:32 +0100
committerJoost Bremmer2024-03-10 03:34:32 +0100
commit5b1bbe2f71b0f7f86f276c25c880c738cd7eea4f (patch)
tree7588882c12f2708728b4fd056218619ed89934f1
parent1de8b3d5664f592ae8383052f461d9dc9765cb56 (diff)
downloadaur-neovim-tagbar.tar.gz
Update to version 3.1.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4add4f426ccc..219f2e9e633a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-tagbar
pkgdesc = Neovim plugin to browse the tags of the current file and get an overview of its structure
- pkgver = 2.7
+ pkgver = 3.1.1
pkgrel = 1
url = https://majutsushi.github.io/tagbar/
install = nvim-doc.install
@@ -9,10 +9,9 @@ pkgbase = neovim-tagbar
license = custom:vim
depends = ctags>=5.5
depends = neovim
- source = neovim-tagbar-2.7.tar.gz::https://github.com/majutsushi/tagbar/archive/v2.7.tar.gz
+ source = neovim-tagbar-3.1.1.tar.gz::https://github.com/preservim/tagbar/archive/refs/tags/v3.1.1.tar.gz
source = LICENSE
- sha512sums = d964d3055f1679aad86b0756cc444a4857eb29ca22f2bd3567ad6c8d073e75d0c8823109038415f5bd1d269bbf8e36da6f34d70fedee54c10f90535ef79ff3c8
+ sha512sums = bbe9215e742dcafa7e943fadd701cd009580301395fba20600a94ce07270e706014abea600fcab5c1d52fc372a9245b60074ab47274d99676edc436a25103445
sha512sums = 01f828e4cf4dee832d2b2976d19163f9e9968089c49a0a33783bd84f3507daf1da0730b12d4dae5bc1edbbf2e419f1ba46adb2347155753c06c94dc30631bf29
pkgname = neovim-tagbar
-
diff --git a/PKGBUILD b/PKGBUILD
index 0eceb1045191..bfbf1013640b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Patrice Peterson <runiq at archlinux dot us>
pkgname=neovim-tagbar
-pkgver=2.7
+pkgver=3.1.1
pkgrel=1
pkgdesc='Neovim plugin to browse the tags of the current file and get an overview of its structure'
url='https://majutsushi.github.io/tagbar/'
@@ -13,19 +13,19 @@ license=('custom:vim')
depends=('ctags>=5.5' 'neovim')
groups=('neovim-plugins')
install=nvim-doc.install
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/majutsushi/tagbar/archive/v${pkgver}.tar.gz
- LICENSE)
-sha512sums=('d964d3055f1679aad86b0756cc444a4857eb29ca22f2bd3567ad6c8d073e75d0c8823109038415f5bd1d269bbf8e36da6f34d70fedee54c10f90535ef79ff3c8'
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/preservim/tagbar/archive/refs/tags/v${pkgver}.tar.gz"
+ "LICENSE")
+sha512sums=('bbe9215e742dcafa7e943fadd701cd009580301395fba20600a94ce07270e706014abea600fcab5c1d52fc372a9245b60074ab47274d99676edc436a25103445'
'01f828e4cf4dee832d2b2976d19163f9e9968089c49a0a33783bd84f3507daf1da0730b12d4dae5bc1edbbf2e419f1ba46adb2347155753c06c94dc30631bf29')
package() {
cd ${pkgname#neovim-}-${pkgver}
_installpath="${pkgdir}/usr/share/nvim/runtime"
- install -Dm 644 doc/tagbar.txt "${_installpath}/doc/tagbar.txt"
- install -Dm 644 autoload/tagbar.vim "${_installpath}/autoload/tagbar.vim"
- install -Dm 644 plugin/tagbar.vim "${_installpath}/plugin/tagbar.vim"
- install -Dm 644 syntax/tagbar.vim "${_installpath}/syntax/tagbar.vim"
- install -Dm 644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -d "${_installpath}"
+ cp -a -t "$_installpath" autoload doc plugin syntax
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: