summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-12-11 12:49:51 -0600
committerLuis Martinez2021-12-11 12:49:51 -0600
commit0f2089f7efd1eb3a2b562d3e501eb232292f6611 (patch)
treee59f14267789541584fde8606636831530f076c7
parent5556ddf54811dba0a52f82d74c3ae4a4726ea2fc (diff)
downloadaur-0f2089f7efd1eb3a2b562d3e501eb232292f6611.tar.gz
add GPG keys to verify sources
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--trouble.install (renamed from neovim-trouble-git.install)0
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe0d45044b72..397d1a0a7654 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = neovim-trouble-git
pkgdesc = A pretty diagnostics list for Neovim powered by LSP
- pkgver = r77.7de8bc4
- pkgrel = 2
+ pkgver = r114.c298a17
+ pkgrel = 1
url = https://github.com/folke/trouble.nvim
- install = neovim-trouble-git.install
+ install = trouble.install
arch = any
groups = neovim-plugins
license = unknown
makedepends = git
- depends = neovim>=0.5.0
+ depends = neovim
provides = neovim-trouble
conflicts = neovim-trouble
- source = neovim-trouble-git::git+https://github.com/folke/trouble.nvim
+ source = neovim-trouble-git::git+https://github.com/folke/trouble.nvim?signed
+ validpgpkeys = E57804F976F0B5CE416F56B341F8B1FBACAE2040
+ validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
sha256sums = SKIP
pkgname = neovim-trouble-git
diff --git a/PKGBUILD b/PKGBUILD
index 2d64caef44b5..7a45a60e0ded 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=neovim-trouble-git
-pkgver=r77.7de8bc4
-pkgrel=2
+pkgver=r114.c298a17
+pkgrel=1
pkgdesc="A pretty diagnostics list for Neovim powered by LSP"
arch=('any')
url="https://github.com/folke/trouble.nvim"
license=('unknown')
groups=('neovim-plugins')
-depends=('neovim>=0.5.0')
+depends=('neovim')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-install="$pkgname.install"
-source=("$pkgname::git+$url")
+install=trouble.install
+source=("$pkgname::git+$url?signed")
sha256sums=('SKIP')
+validpgpkeys=(
+ 'E57804F976F0B5CE416F56B341F8B1FBACAE2040' ## Folke Lemaitre
+ '5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23' ## GitHub
+)
pkgver() {
cd "$pkgname"
@@ -24,6 +28,7 @@ pkgver() {
package() {
cd "$pkgname"
find lua plugin \
- -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
- install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}
diff --git a/neovim-trouble-git.install b/trouble.install
index df3aa44f09cf..df3aa44f09cf 100644
--- a/neovim-trouble-git.install
+++ b/trouble.install