summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Bremmer2016-10-13 17:48:11 +0200
committerJoost Bremmer2016-10-13 17:48:11 +0200
commit9fa92d987e75bbf85801795ed400f9d26ef1a4b7 (patch)
tree7ba965d652f05c879f38b7934c1cbe452a66f593
downloadaur-9fa92d987e75bbf85801795ed400f9d26ef1a4b7.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD37
-rw-r--r--nvim-doc.install14
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed1e31311ee4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neovim-ultisnips
+ pkgdesc = TextMate-style snippets for Neovim.
+ pkgver = 3.1
+ pkgrel = 1
+ url = https://github.com/SirVer/ultisnips
+ install = nvim-doc.install
+ arch = any
+ groups = neovim-plugins
+ license = GPL3
+ makedepends = git
+ depends = neovim
+ depends = python-neovim
+ source = neovim-ultisnips-3.1.tar.gz::https://github.com/SirVer/ultisnips/archive/3.1.tar.gz
+ source = git+https://github.com/honza/vim-snippets.git
+ sha256sums = 32ea72d321f07755e878f640398c72f0a072e56a980a66bdc7bfb41ba85fa6e7
+ sha256sums = SKIP
+
+pkgname = neovim-ultisnips
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7123c0a23024
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# package src/pkg archives, downloaded sources
+*.tar*
+*.tgz
+*.zip
+
+# signed sources
+*.asc
+*.sig
+
+# subfolders, e.g. source or built package trees, vcs
+*/**/
+!neovim-plugins/*
+# backup files
+*~
+*.bak
+pkg
+src
+*xpi
+*tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..462672365317
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Joost Bremmer <toost.b@gmail.com>
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+
+pkgname=neovim-ultisnips
+pkgver=3.1
+pkgrel=1
+pkgdesc='TextMate-style snippets for Neovim.'
+arch=('any')
+url='https://github.com/SirVer/ultisnips'
+license=('GPL3')
+depends=('neovim' 'python-neovim')
+groups=('neovim-plugins')
+install=nvim-doc.install
+makedepends=('git')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/SirVer/ultisnips/archive/${pkgver}.tar.gz"
+ git+https://github.com/honza/vim-snippets.git)
+sha256sums=('32ea72d321f07755e878f640398c72f0a072e56a980a66bdc7bfb41ba85fa6e7'
+ 'SKIP')
+
+package() {
+ cd "${srcdir}/ultisnips-$pkgver"
+
+ install -dm755 "$pkgdir/usr/share/nvim/runtime/"
+ cp -r -t "$pkgdir/usr/share/nvim/runtime/" pythonx after doc ftdetect autoload\
+ ftplugin plugin syntax utils
+
+ cd "${srcdir}/vim-snippets"
+
+ install -dm755 "$pkgdir/usr/share/nvim/runtime/"
+ cp -r -t "$pkgdir/usr/share/nvim/runtime/" UltiSnips autoload snippets
+
+ # compile .pyc and .pyo files (fixes FS#43121)
+ find "${pkgdir}" -name '*.py' -exec python2 -mpy_compile {} +
+ find "${pkgdir}" -name '*.py' -exec python2 -O -mpy_compile {} +
+}
+# vim: sw=2 ts=2 et:
diff --git a/nvim-doc.install b/nvim-doc.install
new file mode 100644
index 000000000000..79795d84c37b
--- /dev/null
+++ b/nvim-doc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating neovim help tags..."
+ /usr/bin/nvim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/nvim/runtime/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}