summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-07-27 14:56:30 +0800
committerSainnhepark2020-07-27 14:56:30 +0800
commit3c1fb39ef64fec34dabf032abd0c9738a4cbdde8 (patch)
tree255d01d47728f40c8c58c52dfd6d8250667e571f
downloadaur-3c1fb39ef64fec34dabf032abd0c9738a4cbdde8.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--vista-neovim-doc.hook11
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22c11f7e1786
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = neovim-vista-git
+ pkgdesc = Viewer & Finder for LSP symbols and tags
+ pkgver = r249.de344a6
+ pkgrel = 1
+ url = https://github.com/liuchengxu/vista.vim
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = neovim
+ optdepends = ctags: ctags support
+ optdepends = neovim-coc: lsp symbols support
+ optdepends = languageclient-neovim: lsp symbols support
+ optdepends = fzf: for searching symbols/tags
+ provides = neovim-vista
+ conflicts = neovim-vista
+ source = vista::git+https://github.com/liuchengxu/vista.vim.git
+ source = vista-neovim-doc.hook
+ sha256sums = SKIP
+ sha256sums = 9e0343333fad74fbd24ad7e97dc4568389409d7dbf98b842937736b6aa952833
+
+pkgname = neovim-vista-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64b7b48f5da4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgname=('neovim-vista-git')
+_pkgname=vista
+pkgver=r249.de344a6
+pkgrel=1
+pkgdesc='Viewer & Finder for LSP symbols and tags'
+arch=('any')
+url='https://github.com/liuchengxu/vista.vim'
+license=('MIT')
+depends=('neovim')
+optdepends=('ctags: ctags support'
+ 'neovim-coc: lsp symbols support'
+ 'languageclient-neovim: lsp symbols support'
+ 'fzf: for searching symbols/tags')
+provides=('neovim-vista')
+conflicts=('neovim-vista')
+source=("${_pkgname}::git+https://github.com/liuchengxu/vista.vim.git"
+ "${_pkgname}-neovim-doc.hook")
+sha256sums=('SKIP'
+ '9e0343333fad74fbd24ad7e97dc4568389409d7dbf98b842937736b6aa952833')
+makedepends=('git')
+_packdir="usr/local/share/nvim/site/pack/${_pkgname}/start/${_pkgname}"
+_variant='neovim'
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ touch doc/tags
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ find autoload doc plugin syntax -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
+}
diff --git a/vista-neovim-doc.hook b/vista-neovim-doc.hook
new file mode 100644
index 000000000000..9f0d5e94caf2
--- /dev/null
+++ b/vista-neovim-doc.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation= Remove
+Type = Path
+Target = usr/local/share/nvim/site/pack/vista/start/vista/doc/
+
+[Action]
+Description = Updating Vim help tags...
+Exec = /usr/bin/nvim -es --cmd ":helptags /usr/local/share/nvim/site/pack/vista/start/vista/doc" --cmd ":q"
+When = PostTransaction