summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-08-03 18:38:18 +0800
committerSainnhepark2020-08-03 18:38:18 +0800
commitf6931e396688962308b9e2d253812120b26bff58 (patch)
treedf727762b13cfcdbcc322dfbe490433be5af185f
parent3c1fb39ef64fec34dabf032abd0c9738a4cbdde8 (diff)
downloadaur-f6931e396688962308b9e2d253812120b26bff58.tar.gz
remove hook
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
-rw-r--r--vista-neovim-doc.hook11
3 files changed, 3 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22c11f7e1786..975e1afb401a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,9 +14,7 @@ pkgbase = neovim-vista-git
provides = neovim-vista
conflicts = neovim-vista
source = vista::git+https://github.com/liuchengxu/vista.vim.git
- source = vista-neovim-doc.hook
sha256sums = SKIP
- sha256sums = 9e0343333fad74fbd24ad7e97dc4568389409d7dbf98b842937736b6aa952833
pkgname = neovim-vista-git
diff --git a/PKGBUILD b/PKGBUILD
index 64b7b48f5da4..a8a83eb8a666 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,8 @@ optdepends=('ctags: ctags support'
'fzf: for searching symbols/tags')
provides=('neovim-vista')
conflicts=('neovim-vista')
-source=("${_pkgname}::git+https://github.com/liuchengxu/vista.vim.git"
- "${_pkgname}-neovim-doc.hook")
-sha256sums=('SKIP'
- '9e0343333fad74fbd24ad7e97dc4568389409d7dbf98b842937736b6aa952833')
+source=("${_pkgname}::git+https://github.com/liuchengxu/vista.vim.git")
+sha256sums=('SKIP')
makedepends=('git')
_packdir="usr/local/share/nvim/site/pack/${_pkgname}/start/${_pkgname}"
_variant='neovim'
@@ -27,16 +25,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd "${srcdir}/${_pkgname}"
- touch doc/tags
-}
-
package() {
cd "${srcdir}/${_pkgname}"
+ nvim -es --cmd ":helptags doc" --cmd ":q"
find autoload doc plugin syntax -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
}
diff --git a/vista-neovim-doc.hook b/vista-neovim-doc.hook
deleted file mode 100644
index 9f0d5e94caf2..000000000000
--- a/vista-neovim-doc.hook
+++ /dev/null
@@ -1,11 +0,0 @@
-[Trigger]
-Operation = Install
-Operation = Upgrade
-Operation= Remove
-Type = Path
-Target = usr/local/share/nvim/site/pack/vista/start/vista/doc/
-
-[Action]
-Description = Updating Vim help tags...
-Exec = /usr/bin/nvim -es --cmd ":helptags /usr/local/share/nvim/site/pack/vista/start/vista/doc" --cmd ":q"
-When = PostTransaction