summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-25 14:23:30 -0500
committerLuis Martinez2021-08-25 14:23:30 -0500
commitfd61f4be3f2f8e46f793f8a6980117a15a3f189e (patch)
tree61b3ee2ffd7343bafdb0216ec448d38c611f9db2
downloadaur-fd61f4be3f2f8e46f793f8a6980117a15a3f189e.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88722a27279d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-zenbones-git
+ pkgdesc = Contrast-focused Neovim colorscheme
+ pkgver = r57.8a4d3ba
+ pkgrel = 1
+ url = https://github.com/mcchrish/zenbones.nvim
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ optdepends = neovim-lush: for zenbones-lua colorscheme
+ provides = neovim-zenbones
+ conflicts = neovim-zenbones
+ source = neovim-zenbones-git::git+https://github.com/mcchrish/zenbones.nvim
+ md5sums = SKIP
+
+pkgname = neovim-zenbones-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36b7ddbc122b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-zenbones-git
+pkgver=r57.8a4d3ba
+pkgrel=1
+pkgdesc="Contrast-focused Neovim colorscheme"
+arch=('any')
+url="https://github.com/mcchrish/zenbones.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('vim-plugin-runtime')
+optdepends=('neovim-lush: for zenbones-lua colorscheme')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd "$pkgname"
+ find colors lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}