summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorexhq2022-10-02 19:13:27 +0330
committerexhq2022-10-02 19:17:22 +0330
commit5af8ced91240db5e6dabe0d8ad4d4e4f0854535e (patch)
treef69cda24a6acc435097e7e63f20c59e5838ef3e0
downloadaur-5af8ced91240db5e6dabe0d8ad4d4e4f0854535e.tar.gz
init files
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05426f6e9cd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = neowofetch-git
+ pkgdesc = a combination of neofetch and uwufetch written in go
+ pkgver = r37.55c749c
+ pkgrel = 1
+ url = https://exhq.gay/neOwOfetch
+ arch = x86_64
+ license = GPL3
+ makedepends = go
+ makedepends = git
+ source = git+https://github.com/exhq/neOwOfetch.git
+ sha256sums = SKIP
+
+pkgname = neowofetch-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b39f3b2a183f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51fefe6e7af8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ECHO <exhq@waifu.club>
+# Contributor: nea <nea@nea.moe>
+
+pkgbase=neowofetch-git
+pkgname=$pkgbase
+license=('GPL3')
+pkgdesc="a combination of neofetch and uwufetch written in go"
+pkgver=r37.55c749c
+pkgrel=1
+url="https://exhq.gay/neOwOfetch"
+depends=()
+makedepends=(go git)
+arch=('x86_64')
+source=("git+https://github.com/exhq/neOwOfetch.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/neOwOfetch
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/neOwOfetch
+ go build .
+}
+
+package() {
+ install -Dm755 $srcdir/neOwOfetch/neowofetch $pkgdir/usr/bin/neowofetch
+}