summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMárton Szabó2018-01-21 17:34:48 +0100
committerMárton Szabó2018-01-21 17:34:48 +0100
commit505f15a3439c77a03a49313adf4b7bb3f8a63955 (patch)
treed307a46ddb8378c6c5695091daa7f70ae8998a08
parent88cf6408ac55a9e12ddb674a0853e095dd6df2e5 (diff)
downloadaur-505f15a3439c77a03a49313adf4b7bb3f8a63955.tar.gz
v0.1.19
added go-md2man makedepend
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a8ecc047e85..d6de06bb8c1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neph-git
pkgdesc = A modern command line job processor
- pkgver = v0.1.18.r0.7d31aad
+ pkgver = v0.1.19.r0.2965255
pkgrel = 1
url = https://tbrand.github.io/neph/
arch = i686
@@ -8,6 +8,7 @@ pkgbase = neph-git
license = MIT
makedepends = git
makedepends = crystal
+ makedepends = go-md2man
depends = glibc
depends = libyaml
provides = neph
diff --git a/PKGBUILD b/PKGBUILD
index b8c2b6e67444..734d6e3f2606 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Márton Szabó < echo "bm90cmFtb0B2aXBtYWlsLmh1Cg=="|base64 -d >
pkgname=neph-git
-pkgver=v0.1.18.r0.7d31aad
+pkgver=v0.1.19.r0.2965255
pkgrel=1
pkgdesc="A modern command line job processor"
arch=('i686' 'x86_64')
url="https://tbrand.github.io/neph/"
license=('MIT')
depends=('glibc' 'libyaml')
-makedepends=('git' 'crystal')
+makedepends=('git' 'crystal' 'go-md2man')
provides=('neph')
conflicts=('neph')
source=('neph::git+https://github.com/tbrand/neph.git')
@@ -22,9 +22,11 @@ pkgver() {
build() {
cd "$srcdir/neph"
crystal build --release src/bin/neph_bin.cr
+ go-md2man -in neph.1.md -out neph.1
}
package() {
cd "$srcdir/neph"
install -Dm 755 neph_bin "$pkgdir/usr/bin/neph"
+ install -Dm 755 neph.1 "$pkgdir/usr/share/man/man1/neph.1"
}