summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredrick Brennan2023-05-03 10:17:53 -0400
committerFredrick Brennan2023-05-03 10:17:53 -0400
commitdbaff55aa1a6066faeb0a044af5b8078aa322c17 (patch)
treeb970f413d9ac15766569f7b613bf0e4e8c6bd983
downloadaur-dbaff55aa1a6066faeb0a044af5b8078aa322c17.tar.gz
v1.3.0
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD60
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68d3d3321a2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = neptune
+ pkgdesc = Platinum UPnP SDK + Neptune C++ Runtime by Axiomatic Software
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://www.plutinosoft.com/platinum-slider/
+ arch = x86_64
+ license = GPL2
+ makedepends = scons
+ makedepends = gcc
+ makedepends = git
+ depends = zlib
+ provides = libNeptune.a
+ provides = libPlatinum.a
+ source = git+https://github.com/plutinosoft/Platinum#tag=1.3.0
+ md5sums = SKIP
+
+pkgname = platinum-upnp
+ pkgdesc = Library / tools for building a UPnP mediaserver. Used behind the scenes by Plex, etc.
+ depends = zlib
+ depends = neptune
+ provides = libPlatinum.a
+
+pkgname = platinum-upnp-docs
+ pkgdesc = Platinum UPnP SDK + Neptune C++ Runtime by Axiomatic Software (documentation)
+ depends = zlib
+ depends = platinum-upnp
+ provides =
+
+pkgname = neptune
+ pkgdesc = Neptune C++ runtime (static library)
+ license = BSD
+ provides = libNeptune.a
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4de8af6a4148
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+#!/bin/bash
+# Maintainer: Fredrick R. Brennan <copypaste@kittens.ph>
+pkgbase=neptune
+pkgname=("platinum-upnp" "platinum-upnp-docs" "neptune")
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Platinum UPnP SDK + Neptune C++ Runtime by Axiomatic Software"
+arch=("x86_64")
+url="https://www.plutinosoft.com/platinum-slider/"
+makedepends=(scons gcc git)
+depends=(zlib)
+provides=(libNeptune.a libPlatinum.a)
+license=('GPL2')
+_gituser=plutinosoft
+_gitrepo=Platinum
+source=("git+https://github.com/$_gituser/$_gitrepo#tag=$pkgver")
+md5sums=("SKIP")
+
+prepare() {
+ cd "$_gitrepo"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$_gitrepo"
+ scons target=x86_64-unknown-linux build_config=Release shared=true
+}
+
+package_platinum-upnp() {
+ pkgdesc="Library / tools for building a UPnP mediaserver. Used behind the scenes by Plex, etc."
+ depends+=(neptune)
+ provides=(libPlatinum.a)
+ cd "$_gitrepo"
+ mkdir -p "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/lib"
+ LIBS=$(find "$srcdir/$_gitrepo/Build/Targets/$arch-unknown-linux/Release/" -type f \( -name '*.a' -and -not -name 'libNeptune.a' \))
+ for lib in $LIBS; do
+ cp "$lib" "$pkgdir/usr/lib/"
+ done
+ find "$srcdir/$_gitrepo/Build/Targets/$arch-unknown-linux/Release/" -type f -executable -exec cp {} "$pkgdir/usr/bin/$pkgname" \;
+}
+
+package_platinum-upnp-docs() {
+ depends+=(platinum-upnp)
+ provides=()
+ pkgdesc="$pkgdesc (documentation)"
+ cd "$_gitrepo"
+ DOCDIR="$pkgdir/usr/share/doc/platinum-upnp"
+ mkdir -p "$DOCDIR"
+ cp -r "$srcdir/$_gitrepo/Docs/Doxygen/html/"* "$DOCDIR/"
+}
+
+package_neptune() {
+ cd "$_gitrepo"
+ pkgdesc="Neptune C++ runtime (static library)"
+ provides=(libNeptune.a)
+ license=("BSD")
+ mkdir -p "$pkgdir/usr/lib"
+ cp "$srcdir/$_gitrepo/Build/Targets/$arch-unknown-linux/Release/libNeptune.a" "$pkgdir/usr/lib/"
+}