summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrzegorz Uriasz2017-09-05 12:19:41 +0200
committerGrzegorz Uriasz2017-09-05 12:19:41 +0200
commit07fd4d86a6fa5f14a041bd5344bbda45bf4f8d0f (patch)
treee22fcf86118bf2cc5c55e5468d8ef5f2777d7fa1
parentc8de88828ebe0303b4f13d14405f5bfb6e31cdb5 (diff)
downloadaur-07fd4d86a6fa5f14a041bd5344bbda45bf4f8d0f.tar.gz
Neptune works correctly now
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 560c3bf4917e..a168680aae4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = neptune-cli
depends = python
depends = python-virtualenv
depends = python-pip
+ depends = python-pillow
source = LICENSE
sha256sums = cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30
diff --git a/PKGBUILD b/PKGBUILD
index f2ce2f9b4a77..d8fe9703737d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,18 @@ pkgdesc="Neptune client library"
arch=('any')
url="https://neptune.ml/"
license=('Apache')
-depends=('python' 'python-virtualenv' 'python-pip')
+depends=('python' 'python-virtualenv' 'python-pip' 'python-pillow')
source=("LICENSE")
sha256sums=("cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30")
build() {
cd "${srcdir}"
virtualenv3 ./neptune-cli
- neptune-cli/bin/pip install -U neptune-cli
+ ./neptune-cli/bin/pip install --no-compile -U neptune-cli
+ yes | ./neptune-cli/bin/pip uninstall pillow
virtualenv3 --relocatable ./neptune-cli
+ sed -i "s?${srcdir}?/opt?" ./neptune-cli/bin/activate
+ sed -i -e "s@fin.read()@ b\"import sys\\\\nsys.path.append(\\\\\"/usr/lib/python3.6/site-packages\\\\\")\\\\n\"+&@" ./neptune-cli/lib/python3.6/site-packages/past/builtins/misc.py
}
package() {
@@ -26,6 +29,8 @@ package() {
mkdir "./usr"
mkdir "./usr/bin"
+ cp -r "/usr/lib/python3.6/site-packages/PIL" "./opt/neptune-cli/lib/python3.6/site-packages/PIL"
+
echo "#!/usr/bin/env bash
source /opt/neptune-cli/bin/activate
function finish {