summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSon Tran2017-08-13 00:39:18 -0700
committerSon Tran2017-08-13 00:39:18 -0700
commit34a53c1247ec753e4d834494a62338de7206bb4b (patch)
tree415f93087cf83d3ff6d0867fc024afff5b4253a5
parent6f0914e22a99879233724b78ce4121b3c172fae5 (diff)
downloadaur-34a53c1247ec753e4d834494a62338de7206bb4b.tar.gz
Add mono fonts
The v1.1.0 already fixed the conflict between mono and non-mono variants.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44987d3eb57e..5eedc50a61bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nerd-fonts-complete
pkgdesc = collection of over 20 patched fonts (complete variant) for powerline, devicons, and vim-devicons: includes Droid Sans, Meslo, AnonymousPro, ProFont, Inconsolta, and many more
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ryanoasis/nerd-fonts
install = nerd-fonts-complete.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 011a99bddcf0..f7ece53841d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: glider <samtron1412 {at} gmail {dot} com>
pkgname=nerd-fonts-complete
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="collection of over 20 patched fonts (complete variant) for \
powerline, devicons, and vim-devicons: includes Droid Sans, \
Meslo, AnonymousPro, ProFont, Inconsolta, and many more"
@@ -23,6 +23,7 @@ prepare() {
#
# Start constructing `find` expression
#
+ # Join all the array elements of $3 by a separate $2 and return to $1
implode() {
# $1 is return variable name
# $2 is sep
@@ -31,18 +32,18 @@ prepare() {
shift 3 || shift $(($#))
printf -v "$retname" "%s" "$ret${@/#/$sep}"
}
- find_include="-and -name '*Complete*'"
+ find_include=
find_exclude=
+ # Include things
+ include=("Complete")
+ if [ ! -z "${include[*]}" ]; then
+ implode find_include "*' -and -name '*" "${include[@]}"
+ find_include="-and -name '*${find_include}*'"
+ fi
+
# Exclude everything we didn’t include
- exclude=("Font Awesome" "Font Linux" "Octicons" "Pomicons" "Nerd Font*Mono" "Windows Compatible")
- for delete in "${include[@]}"; do
- exclude=( "${exclude[@]/$delete}" )
- done
- # Delete empty elements
- for i in "${!exclude[@]}"; do
- [ "${exclude[$i]}" = '' ] && unset exclude[$i]
- done
+ exclude=("Font Awesome" "Font Linux" "Octicons" "Pomicons" "Windows Compatible")
if [ ! -z "${exclude[*]}" ]; then
implode find_exclude "*' -and \! -name '*" "${exclude[@]}"
find_exclude="-and \! -name '*${find_exclude}*'"
@@ -56,6 +57,7 @@ prepare() {
while IFS= read -r -d $'\0'; do
files+=("$REPLY")
done < <(eval "$find_command")
+
#
# Remove duplicates (i.e. when both otf and ttf version present)
#