summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2018-08-15 13:58:17 +0200
committerAlexander Fasching2018-08-15 13:58:17 +0200
commita3a44ce5b126769c273d6bb2a3e751875e429e96 (patch)
tree5b2c4a972a87e331e223c9d110ace8334a8f3055
downloadaur-a3a44ce5b126769c273d6bb2a3e751875e429e96.tar.gz
Initial package based on Inconsolata package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6015770cadb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-droid-sans-mono
+ pkgdesc = Patched font Droid Sans Mono from the nerd-fonts library
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-droid-sans-mono
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/DroidSansMono.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.0.0/LICENSE
+ sha1sums = e5235aa39d2beae38c22d8e2381475f18b97b445
+ sha1sums = 92fdad3c8babc0473da5f03e41fb1151417ab386
+
+pkgname = nerd-fonts-droid-sans-mono
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8601430c996e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alexander Fasching <fasching.a91@gmail.com>
+pkgname=nerd-fonts-droid-sans-mono
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Patched font Droid Sans Mono from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=('nerd-fonts-droid-sans-mono')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/DroidSansMono.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=('e5235aa39d2beae38c22d8e2381475f18b97b445'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}