summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlague Doctor2018-10-22 18:54:15 +1100
committerPlague Doctor2018-10-22 18:54:15 +1100
commitc1c06c5cb839994bb89f6c65b563c96578994cf0 (patch)
treeef09f533da55013b8fd4451c8f17c35573d8992b
downloadaur-c1c06c5cb839994bb89f6c65b563c96578994cf0.tar.gz
Nerd-Fonts FantasqueSansMono
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD24
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a4c5d707666
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Oct 22 07:53:13 UTC 2018
+pkgbase = nerd-fonts-fantasque-sans-mono
+ pkgdesc = Patched font FantasqueSansMono from the nerd-fonts library
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-fantasque-sans-mono
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/FantasqueSansMono.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.0.0/LICENSE
+ sha1sums = 9c7331eab8f1cb09cb9546bad0b1fa3280e50662
+ sha1sums = 92fdad3c8babc0473da5f03e41fb1151417ab386
+
+pkgname = nerd-fonts-fantasque-sans-mono
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b0bc56d0bf51
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+LICENSE
+*.xz
+pkg
+src
+*.zip
+*.orig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b77b4346c80c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Plague-doctor <plague at privacyrequired dot com >
+
+pkgname=nerd-fonts-fantasque-sans-mono
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Patched font FantasqueSansMono from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=('nerd-fonts-fantasque-sans-mono')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("${url}/releases/download/v$pkgver/FantasqueSansMono.zip"
+ "${url}/raw/v$pkgver/LICENSE")
+sha1sums=('9c7331eab8f1cb09cb9546bad0b1fa3280e50662'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" \
+ -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+