summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Quinn2018-05-11 15:57:59 -0400
committerJoseph Quinn2018-05-11 15:57:59 -0400
commit19ae23d3b79e63bd881a054a54498bc9ba90082a (patch)
tree23e40dc1f799e2c45d9c7f8052c1768ba010a28b
downloadaur-19ae23d3b79e63bd881a054a54498bc9ba90082a.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD19
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa98727a9191
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nerd-fonts-inconsolata
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ license = MIT
+ makedepends = fontconfig
+ provides = nerd-fonts-inconsolata
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ conflicts = nerd-fonts-complete-mono-glyphs
+ conflicts = nerd-fonts-gabmus
+ conflicts = nerd-fonts-ricty
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/Inconsolata.zip
+ sha1sums = 5289f5069db1058fbdff0017b4098796e2042a11
+
+pkgname = nerd-fonts-inconsolata
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..af99c9145401
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
+# End of https://www.gitignore.io/api/archlinuxpackages \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f35d5cb86fde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Joseph R. Quinn <quinn period josephr at protonmail dot com>
+pkgname=nerd-fonts-inconsolata
+pkgver=2.0.0
+pkgrel=1
+pkgdesc=""
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=()
+makedepends=('fontconfig')
+provides=('nerd-fonts-inconsolata')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete' 'nerd-fonts-complete-mono-glyphs'
+ 'nerd-fonts-gabmus' 'nerd-fonts-ricty')
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Inconsolata.zip")
+sha1sums=('5289f5069db1058fbdff0017b4098796e2042a11')
+
+package() {
+ find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
+}