summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2023-01-23 11:34:36 +0100
committerD3SOX2023-01-23 11:34:36 +0100
commit8a54f7706cb9f1beae468f68e3f78845d4696b72 (patch)
treea93eb9159d584f0d47ac9a13d047d9fe3d1cb5b1
parentdf02ebe9772c54495b31a7573e13edce9c5d6010 (diff)
downloadaur-8a54f7706cb9f1beae468f68e3f78845d4696b72.tar.gz
update to nerd-fonts 2.3.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--allow-glyphdir.diff21
3 files changed, 10 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6034fc510081..0e29febe58cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nerd-fonts-inter
pkgdesc = Inter Font, patched with the Nerd Fonts Patcher
- pkgver = 3.19_2.1.0
+ pkgver = 3.19_2.3.1
pkgrel = 2
url = https://github.com/rsms/inter/
arch = any
@@ -12,12 +12,10 @@ pkgbase = nerd-fonts-inter
makedepends = subversion
makedepends = parallel
source = https://github.com/rsms/inter/releases/download/v3.19/Inter-3.19.zip
- source = font-patcher-2.1.0::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v2.1.0/font-patcher
- source = allow-glyphdir.diff
- source = svn+https://github.com/ryanoasis/nerd-fonts/tags/v2.1.0/src/glyphs
+ source = font-patcher-2.3.1::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v2.3.1/font-patcher
+ source = svn+https://github.com/ryanoasis/nerd-fonts/tags/v2.3.1/src/glyphs
sha256sums = 150ab6230d1762a57bebf35dfc04d606ff91598a31d785f7f100356ecdcc0032
- sha256sums = 3377615be4271f8bdeef66e6f2f82ac3f3cfb7b5677abe7b8e189409da048859
- sha256sums = 6fad8dead6215b1d8cedbbce3d1bc1fc7c1b0bb06ea70518334bd443a7ba543f
+ sha256sums = a6f2c45d84b29fcb13575d9fe778545ba3b0200efc0e5fb66ce679108f43f397
sha256sums = SKIP
pkgname = nerd-fonts-inter
diff --git a/PKGBUILD b/PKGBUILD
index ace314f2ce86..8040d8412bed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=nerd-fonts-inter
_interver=3.19
-_nfver=2.1.0
+_nfver=2.3.1
pkgver="${_interver}_${_nfver}"
pkgrel=2
pkgdesc="Inter Font, patched with the Nerd Fonts Patcher"
@@ -9,13 +9,13 @@ arch=('any')
url='https://github.com/rsms/inter/'
license=('custom:OFL')
makedepends=('git' 'p7zip' 'python' 'fontforge' 'subversion' 'parallel')
-source=("https://github.com/rsms/inter/releases/download/v$_interver/Inter-$_interver.zip" "font-patcher-$_nfver::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v$_nfver/font-patcher" "allow-glyphdir.diff" "svn+https://github.com/ryanoasis/nerd-fonts/tags/v$_nfver/src/glyphs")
-sha256sums=('150ab6230d1762a57bebf35dfc04d606ff91598a31d785f7f100356ecdcc0032' '3377615be4271f8bdeef66e6f2f82ac3f3cfb7b5677abe7b8e189409da048859' '6fad8dead6215b1d8cedbbce3d1bc1fc7c1b0bb06ea70518334bd443a7ba543f' 'SKIP')
+source=("https://github.com/rsms/inter/releases/download/v$_interver/Inter-$_interver.zip" "font-patcher-$_nfver::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v$_nfver/font-patcher" "svn+https://github.com/ryanoasis/nerd-fonts/tags/v$_nfver/src/glyphs")
+sha256sums=('150ab6230d1762a57bebf35dfc04d606ff91598a31d785f7f100356ecdcc0032'
+ 'a6f2c45d84b29fcb13575d9fe778545ba3b0200efc0e5fb66ce679108f43f397'
+ 'SKIP')
build() {
- _patcher="font-patcher-$_nfver-glyphdir"
- # apply patch to font-patcher to allow using custom glyph directory
- patch -p1 --follow-symlinks -o "$_patcher" < allow-glyphdir.diff
+ _patcher="font-patcher-$_nfver"
# patch fonts
cd "$srcdir"
mkdir -p "$srcdir/patched"
diff --git a/allow-glyphdir.diff b/allow-glyphdir.diff
deleted file mode 100644
index 2934c4532c51..000000000000
--- a/allow-glyphdir.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/font-patcher-2.1.0 b/font-patcher-2.1.0
-index 815d1fd48..55169be26 100755
---- a/font-patcher-2.1.0
-+++ b/font-patcher-2.1.0
-@@ -85,7 +85,7 @@ class font_patcher:
- if symfont:
- symfont.close()
- symfont = None
-- symfont = fontforge.open(__dir__ + "/src/glyphs/" + patch['Filename'])
-+ symfont = fontforge.open(self.args.glyphdir + patch['Filename'])
-
- # Match the symbol font size to the source font size
- symfont.em = self.sourceFont.em
-@@ -143,6 +143,7 @@ class font_patcher:
- parser.add_argument('--custom', dest='custom', default=False, type=str, nargs='?', help='Specify a custom symbol font. All new glyphs will be copied, with no scaling applied.')
- parser.add_argument('-ext', '--extension', dest='extension', default="", type=str, nargs='?', help='Change font file type to create (e.g., ttf, otf)')
- parser.add_argument('-out', '--outputdir', dest='outputdir', default=".", type=str, nargs='?', help='The directory to output the patched font file to')
-+ parser.add_argument('--glyphdir', dest='glyphdir', default=__dir__ + "/src/glyphs/", type=str, nargs='?', help='Path to glyphs to be used for patching')
-
- # progress bar arguments - https://stackoverflow.com/questions/15008758/parsing-boolean-values-with-argparse
- progressbars_group_parser = parser.add_mutually_exclusive_group(required=False)