summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerpGusta2018-11-08 20:20:12 +0530
committerDerpGusta2018-11-08 20:20:12 +0530
commit98d31189daa478688cefac92e59282d9ba129fde (patch)
tree9a3631df51e46e2616d76684736ffe4a29069b1f
downloadaur-98d31189daa478688cefac92e59282d9ba129fde.tar.gz
first commit and first PKGBUILD. Yay!!
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6acb0282e24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-iosevka
+ pkgdesc = Patched Iosevka font from the nerd-fonts library
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-iosevka
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/Iosevka.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.0.0/LICENSE
+ sha1sums = e575e85ce0e336a67b8daabf7c37e1692f017e31
+ sha1sums = 92fdad3c8babc0473da5f03e41fb1151417ab386
+
+pkgname = nerd-fonts-iosevka
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebd204042953
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sri Harsha <toletysriharsha9@gmail.com>
+pkgname=nerd-fonts-iosevka
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Patched Iosevka font from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=('nerd-fonts-iosevka')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Iosevka.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=('e575e85ce0e336a67b8daabf7c37e1692f017e31'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+