summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph R. Quinn2020-02-03 16:04:08 -0500
committerJoseph R. Quinn2020-02-03 16:04:08 -0500
commit2d8c93655c6ef114fe74252859802664467dd4ca (patch)
tree406ff08e486615aecf5f12aa31adbd68bf7cddb7
downloadaur-2d8c93655c6ef114fe74252859802664467dd4ca.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD24
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e62aec8fae8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-liberation-mono
+ pkgdesc = Patched font Liberation Mono from the nerd-fonts library
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-liberation-mono
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.1.0/LiberationMono.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.1.0/LICENSE
+ sha1sums = 6cfd7cd5be33b9f39afa2bd14987ff72ca3a664c
+ sha1sums = 92fdad3c8babc0473da5f03e41fb1151417ab386
+
+pkgname = nerd-fonts-liberation-mono
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e197dda3b1ab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+LICENSE
+
+# End of https://www.gitignore.io/api/archlinuxpackages \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b33d8d9fb485
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Packager: Joseph R. Quinn <quinn.josephr@protonmail.com>
+# Maintainer: Joseph R. Quinn <quinn.josephr@protonmail.com>
+pkgname=nerd-fonts-liberation-mono
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Patched font Liberation Mono from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=("${pkgname}")
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/LiberationMono.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=('6cfd7cd5be33b9f39afa2bd14987ff72ca3a664c'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}