summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph R. Quinn2022-08-31 18:28:27 -0400
committerJoseph R. Quinn2022-08-31 18:28:27 -0400
commit82c066f0a1c36333c18fe74fa3ad0d99dfbadabb (patch)
treea3ccc947ddb72eddad082100ada09e7a9a3b8f2d
parent120a28bc8110aef2027e52f0961157835a37bdf8 (diff)
downloadaur-82c066f0a1c36333c18fe74fa3ad0d99dfbadabb.tar.gz
Fixing installation issues
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28e6fe12f9a4..0d1fb92cd9f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nerd-fonts-liberation-mono
pkgdesc = Patched font Liberation Mono from the nerd-fonts library
pkgver = 2.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ryanoasis/nerd-fonts
arch = any
groups = nerd-fonts
@@ -10,9 +10,9 @@ pkgbase = nerd-fonts-liberation-mono
provides = nerd-fonts-liberation-mono
conflicts = nerd-fonts-git
conflicts = nerd-fonts-complete
- source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.2.1/LiberationMono.zip
+ source = 2.2.1.zip::https://github.com/ryanoasis/nerd-fonts/releases/download/v2.2.1/LiberationMono.zip
source = https://github.com/ryanoasis/nerd-fonts/raw/v2.2.1/LICENSE
- b2sums = 9c20019db3f39ebf0923458a2ab07f4febb1c87fd3efee336cf2c989f65e3b84497da2eb0e8575c47aa3cea8572fe6d601309ea7908fbb4f6f8e4ce447701b81
+ b2sums = f28d9c6f1c4547e731784aae39624f75815438c306ea39edde5a6707a60ef890667e33e3189e560dc4f166d09ddc6440a65dda736fa367628cc57eebecce4857
b2sums = 386dfcb5ead367bfc44fc55f7e94548c03bdb24ca088ab56f9609e7cdaa3eab9c56b548966feaf7312da606b645e9af35556fc212132733efcdbcc17397c808a
pkgname = nerd-fonts-liberation-mono
diff --git a/PKGBUILD b/PKGBUILD
index c236b24432f7..53931635877d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Joseph R. Quinn <quinn.josephr@protonmail.com>
pkgname=nerd-fonts-liberation-mono
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Patched font Liberation Mono from the nerd-fonts library"
arch=("any")
url="https://github.com/ryanoasis/nerd-fonts"
@@ -11,14 +11,14 @@ depends=('fontconfig')
provides=("${pkgname}")
conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
groups=("nerd-fonts")
-source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/LiberationMono.zip"
+source=("$pkgver.zip::https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/LiberationMono.zip"
"https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
-b2sums=('9c20019db3f39ebf0923458a2ab07f4febb1c87fd3efee336cf2c989f65e3b84497da2eb0e8575c47aa3cea8572fe6d601309ea7908fbb4f6f8e4ce447701b81'
+b2sums=('f28d9c6f1c4547e731784aae39624f75815438c306ea39edde5a6707a60ef890667e33e3189e560dc4f166d09ddc6440a65dda736fa367628cc57eebecce4857'
'386dfcb5ead367bfc44fc55f7e94548c03bdb24ca088ab56f9609e7cdaa3eab9c56b548966feaf7312da606b645e9af35556fc212132733efcdbcc17397c808a')
package() {
find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
-
+
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}