summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRocky Prabowo2019-11-13 13:45:12 +0700
committerRocky Prabowo2019-11-13 13:45:12 +0700
commitb64a8a950dcfef8bd8da26d1c4144eb7ab54339c (patch)
tree8a57e63849e84461be11d0f612ddc5859ef9110b
downloadaur-b64a8a950dcfef8bd8da26d1c4144eb7ab54339c.tar.gz
Initial commit, nerd-fonts 2.0.0
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ed3966744b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-meslo
+ pkgdesc = Standalone Meslo (ttf-meslo) patched font from the nerd-fonts library
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-meslo
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/Meslo.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.0.0/LICENSE
+ sha1sums = 39ef22188db13029172d60262083edda38f73cce
+ sha1sums = 92fdad3c8babc0473da5f03e41fb1151417ab386
+
+pkgname = nerd-fonts-meslo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d26a79fbc151
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Packager: Rocky Prabowo <rocky at lazycats dot id>
+# Maintainer: Rocky Prabowo <rocky at lazycats dot id>
+
+_pkgbase='nerd-fonts'
+_font_name='Meslo'
+_font_pkgbase='ttf-meslo'
+_font_pkgname='meslo'
+_nerdfonts_source='Meslo.zip'
+
+pkgname=${_pkgbase}-${_font_pkgname}
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Standalone ${_font_name} (${_font_pkgbase}) patched font from the ${_pkgbase} library"
+arch=("any")
+url="https://github.com/ryanoasis/${_pkgbase}"
+license=('MIT')
+depends=('fontconfig')
+provides=( ${pkgname} )
+conflicts=( ${_pkgbase}-git ${_pkgbase}-complete )
+groups=( ${_pkgbase} )
+source=("https://github.com/ryanoasis/${_pkgbase}/releases/download/v${pkgver}/${_nerdfonts_source}"
+ "https://github.com/ryanoasis/${_pkgbase}/raw/v${pkgver}/LICENSE")
+sha1sums=('39ef22188db13029172d60262083edda38f73cce'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "${pkgdir}/usr/share/fonts/OTF/{}" \;
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "${pkgdir}/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}