summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWutraz2020-03-31 10:38:25 +0100
committerWutraz2020-03-31 10:38:25 +0100
commit05e38f2c32801b77094013e543435e57d5986cce (patch)
treea7ff40e10e8473ac01d12bb1bc27f378d680fd6b
downloadaur-05e38f2c32801b77094013e543435e57d5986cce.tar.gz
Add first release from Nerd Fonts V2.1.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7e973058b72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-monoid
+ pkgdesc = Patched font Monoid from the nerd-fonts library
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-monoid
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.1.0/Monoid.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.1.0/LICENSE
+ md5sums = ebcefb7d20e746d58dd6448e6f984326
+ md5sums = 1b95f7668f3a4440b0d404e8dc3ccd9c
+
+pkgname = nerd-fonts-monoid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b507da46c4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Rónán Carrigan <ronan.carrigan at gmail dot com>
+# Adapted from PKGBUILD for nerd-fonts-fira-code (https://aur.archlinux.org/packages/nerd-fonts-fira-code/)
+
+pkgname=nerd-fonts-monoid
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Patched font Monoid from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=('nerd-fonts-monoid')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Monoid.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+md5sums=('ebcefb7d20e746d58dd6448e6f984326'
+ '1b95f7668f3a4440b0d404e8dc3ccd9c')
+
+package() {
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+