summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Fode2019-01-14 18:52:18 +0100
committerNick Fode2019-01-14 18:57:17 +0100
commit5da1165a0334e602d264a86e286cee2b10d60175 (patch)
tree791331b575d8bf5a412f06ffc291abe190db9c4d
downloadaur-5da1165a0334e602d264a86e286cee2b10d60175.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--nerd-fonts-noto-sans-regular-complete.install27
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..347b5b666fbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nerd-fonts-noto-sans-regular-complete
+ pkgdesc = Noto Sans Regular Nerd Font complete
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ install = nerd-fonts-noto-sans-regular-complete.install
+ arch = any
+ license = MIT
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = Noto-Sans-Regular-Nerd-Font-Complete.ttf::https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v2.0.0/patched-fonts/Noto/Sans/complete/Noto%20Sans%20Regular%20Nerd%20Font%20Complete.ttf
+
+pkgname = nerd-fonts-noto-sans-regular-complete
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1106ce7e8421
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Nick Fod <nickfode@posteo.de>
+
+pkgname=nerd-fonts-noto-sans-regular-complete
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Noto Sans Regular Nerd Font complete"
+arch=('any')
+url="https://github.com/ryanoasis/nerd-fonts"
+_raw_url="https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v${pkgver}/patched-fonts"
+license=('MIT')
+depends=('fontconfig' 'xorg-font-utils')
+install="${pkgname}.install"
+md5sums=("SKIP")
+source=(
+ "Noto-Sans-Regular-Nerd-Font-Complete.ttf::${_raw_url}/Noto/Sans/complete/Noto%20Sans%20Regular%20Nerd%20Font%20Complete.ttf"
+)
+package() {
+
+ install -dm0755 ${pkgdir}/usr/share/fonts/TTF
+ install -Dm0644 ${srcdir}/*.ttf ${pkgdir}/usr/share/fonts/TTF
+
+}
+
diff --git a/nerd-fonts-noto-sans-regular-complete.install b/nerd-fonts-noto-sans-regular-complete.install
new file mode 100644
index 000000000000..ae2c7c25a78f
--- /dev/null
+++ b/nerd-fonts-noto-sans-regular-complete.install
@@ -0,0 +1,27 @@
+msg() {
+
+ echo -en "[1;34m::[0;1m ${@}[0m"
+
+}
+
+post_install() {
+
+ msg 'Updating font cache...'
+ fc-cache -s > /dev/null 2>&1
+ mkfontscale /usr/share/fonts/TTF > /dev/null 2>&1
+ mkfontdir /usr/share/fonts/TTF > /dev/null 2>&1
+ echo ' done!'
+
+}
+
+post_upgrade() {
+
+ post_install
+
+}
+
+post_remove() {
+
+ post_install
+
+}