summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2018-08-19 14:11:16 +0200
committerAlexander Fasching2018-08-19 14:11:16 +0200
commit1dbeb46f212eeafa95cc2ae09f6882a3fb9a6736 (patch)
tree7ee0e876777a0d9446d36ffea2196346b4c10c6b
downloadaur-1dbeb46f212eeafa95cc2ae09f6882a3fb9a6736.tar.gz
Initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e66edc4e9d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-roboto-mono
+ pkgdesc = Patched font Roboto Mono from the nerd-fonts library
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-roboto-mono
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/RobotoMono.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.0.0/LICENSE
+ sha1sums = bf637b3e62aa00c81f06333544b7c8ab11cc206f
+ sha1sums = 92fdad3c8babc0473da5f03e41fb1151417ab386
+
+pkgname = nerd-fonts-roboto-mono
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a0749c69bfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alexander Fasching <fasching.a91@gmail.com>
+pkgname=nerd-fonts-roboto-mono
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Patched font Roboto Mono from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=('nerd-fonts-roboto-mono')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/RobotoMono.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=('bf637b3e62aa00c81f06333544b7c8ab11cc206f'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}