summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Chen2020-10-17 17:45:35 -0700
committerWilliam Chen2020-10-17 17:45:35 -0700
commit3b91a4aed50bc005e3b08b51bbcb85b287736bd4 (patch)
tree496c000443c69aa63715c55b8954f2aaf9c7c778
downloadaur-3b91a4aed50bc005e3b08b51bbcb85b287736bd4.tar.gz
INITIAL COMMIT
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28ffed7c3736
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-space-code-pro
+ pkgdesc = Patched font SpaceCodePro from Nerd Fonts Library
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-space-code-pro
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.1.0/SpaceCodePro.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.1.0/LICENSE
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = nerd-space-code-pro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbbfc6c0fb52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Packager: William Chen <edoc.www@gmail.com>
+# Maintainer: William Chen <edoc.www@gmail.com>
+
+pkgname=nerd-space-code-pro
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Patched font SpaceCodePro from Nerd Fonts Library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=("${pkgname}")
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/SpaceCodePro.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=(SKIP
+ SKIP)
+
+package() {
+ find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+