summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Quinn2018-05-15 15:26:09 -0400
committerJoseph Quinn2018-05-15 15:26:09 -0400
commitc78a4b6328d8f09ed00a0996dc0e58dd92365caf (patch)
tree527175f01f8ea7bf5e402c880efa002aff5d23b6
downloadaur-c78a4b6328d8f09ed00a0996dc0e58dd92365caf.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD22
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d89be23f72c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nerd-fonts-terminus
+ pkgdesc = Patched font Terminus from the nerd-fonts library
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/ryanoasis/nerd-fonts
+ arch = any
+ groups = nerd-fonts
+ license = MIT
+ depends = fontconfig
+ provides = nerd-fonts-terminus
+ conflicts = nerd-fonts-git
+ conflicts = nerd-fonts-complete
+ source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.0.0/Terminus.zip
+ source = https://github.com/ryanoasis/nerd-fonts/raw/v2.0.0/LICENSE
+ sha1sums = 7c1c214037c24831d972c6fe39af54ac15ecd554
+ sha1sums = 92fdad3c8babc0473da5f03e41fb1151417ab386
+
+pkgname = nerd-fonts-terminus
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cce34ca5a919
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+LICENSE
+
+
+# End of https://www.gitignore.io/api/archlinuxpackages \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93714947b8c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Joseph R. Quinn <quinn period josephr at protonmail dot com>
+pkgname=nerd-fonts-terminus
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Patched font Terminus from the nerd-fonts library"
+arch=("any")
+url="https://github.com/ryanoasis/nerd-fonts"
+license=('MIT')
+depends=('fontconfig')
+provides=('nerd-fonts-terminus')
+conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
+groups=("nerd-fonts")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Terminus.zip"
+ "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
+sha1sums=('7c1c214037c24831d972c6fe39af54ac15ecd554'
+ '92fdad3c8babc0473da5f03e41fb1151417ab386')
+
+package() {
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}