summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanpi2023-05-02 18:57:49 +0200
committerSanpi2023-05-02 18:57:49 +0200
commitc16e8055103f252bc895caa2fd5b255b814324cd (patch)
tree442147ea25f3979e1e211773d05cf17612cd6d11
downloadaur-c16e8055103f252bc895caa2fd5b255b814324cd.tar.gz
v0.2.2
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91911d7b5e50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nerdfix
+ pkgdesc = nerdfix helps you to find/fix obsolete Nerd Font icons in your project.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/loichyan/nerdfix
+ arch = x86_64
+ license = MIT
+ license = Apache
+ makedepends = cargo
+ source = https://github.com/loichyan/nerdfix/archive/refs/tags/v0.2.2.tar.gz
+ sha256sums = 380d7853c4fb1f8b041fef6126248ac935e2fcdc87b137e0a00b39958a61f498
+
+pkgname = nerdfix
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1295580f1017
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/*.pkg.tar.*
+/*.tar.gz
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d15c8aa4ef73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sanpi <sanpi+aur@homecomputing.fr>
+pkgname=nerdfix
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="nerdfix helps you to find/fix obsolete Nerd Font icons in your project."
+url="https://github.com/loichyan/$pkgname"
+arch=("x86_64")
+license=("MIT" "Apache")
+makedepends=("cargo")
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('380d7853c4fb1f8b041fef6126248ac935e2fcdc87b137e0a00b39958a61f498')
+
+build()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package()
+{
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm 755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm 644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}