summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112019-01-01 20:02:35 +0100
committerjose17112019-01-01 20:02:35 +0100
commit5c41ad73328459b7ead8169b1a7a76f4906d018a (patch)
tree7751dce83272d69fb1403294c5e4eb8f967c9030
downloadaur-5c41ad73328459b7ead8169b1a7a76f4906d018a.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--nerolinux.install24
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc4789e5065f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Jan 1 19:02:24 UTC 2019
+pkgbase = nerolinux3
+ pkgdesc = Nero Burning ROM for linux (legacy version)
+ pkgver = 3.5.3.1
+ pkgrel = 1
+ url = http://www.nero.com
+ install = nerolinux.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = rpmextract
+ provides = nerolinux
+ conflicts = nerolinux
+ source = nerolinux-3.5.3.1-1.i386.rpm::https://soft.sibnet.ru/get/?id=19137
+ md5sums = 73c1090e85fbf7c1df130374117ce93b
+ depends_i686 = gtk2
+ depends_x86_64 = lib32-gtk2
+
+pkgname = nerolinux3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82af3adca1be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=nerolinux3
+pkgver=3.5.3.1
+pkgrel=1
+pkgdesc="Nero Burning ROM for linux (legacy version)"
+url="http://www.nero.com"
+license=('custom')
+depends_i686=('gtk2')
+depends_x86_64=('lib32-gtk2')
+conflicts=('nerolinux')
+provides=('nerolinux')
+makedepends=('rpmextract')
+arch=('i686' 'x86_64')
+source=("nerolinux-${pkgver}-1.i386.rpm"::'https://soft.sibnet.ru/get/?id=19137')
+md5sums=('73c1090e85fbf7c1df130374117ce93b')
+install=nerolinux.install
+
+package() {
+ cd "$pkgdir"
+ rpmextract.sh "$srcdir/nerolinux-${pkgver}-1.i386.rpm"
+
+ chmod a+rx -R *
+ find . -type f -exec chmod -x \{\} \;
+ chmod +x usr/bin/{nero,nerocmd}
+
+ mkdir -p usr/share/licenses/nerolinux
+ mv usr/share/doc/nero/EULA* usr/share/licenses/nerolinux
+}
diff --git a/nerolinux.install b/nerolinux.install
new file mode 100644
index 000000000000..b422c73fdb2b
--- /dev/null
+++ b/nerolinux.install
@@ -0,0 +1,24 @@
+# arg 1: the new package version
+post_install() {
+ echo "For Nero to be able to detect CD/DVD drives,"
+ echo "add yourself to the 'optical' group."
+ echo "Also make sure sg module is loaded."
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ echo "For Nero to be able to detect CD/DVD drives,"
+ echo "add yourself to the 'optical' group."
+ echo "Also make sure sg module is loaded."
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*