summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBeth Harmon2022-09-21 16:22:17 +0100
committerBeth Harmon2022-09-21 16:22:17 +0100
commitf206c148938035e5bc5cb0b8e597f43d2db283a1 (patch)
tree1abeb88f2a8bee85b44ab398a57bc30efff1f81c
parent6c1ce50332bb77c0ae107214f92a66e5824792bc (diff)
downloadaur-nerolinux4.tar.gz
Add edits by user visious
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD68
-rw-r--r--nerolinux.install24
3 files changed, 73 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e74c0dffd1c..c4fe145a1efc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,30 @@
pkgbase = nerolinux4
- pkgdesc = Nero Burning ROM for linux (legacy version)
+ pkgdesc = Nero Burning ROM for linux
pkgver = 4.0.0.0b
- pkgrel = 2
- url = http://www.nero.com
- install = nerolinux.install
- arch = i686
+ pkgrel = 3
+ url = http://nerolinux.nero.com
arch = x86_64
- license = custom
- provides = nerolinux
- conflicts = nerolinux
- source = nerolinux-4.0.0.0b-x86.rpm::http://nero-mirror.com/support/NeroLINUX/nerolinux-4.0.0.0b-x86.rpm
- md5sums = f49f49c588729c2afdbecb546d9b6041
- depends_i686 = gtk2
- depends_i686 = pangox-compat
- depends_x86_64 = lib32-gtk2
- depends_x86_64 = lib32-pangox-compat
+ license = Nero AG
+ depends = atk
+ depends = cairo
+ depends = desktop-file-utils
+ depends = fontconfig
+ depends = gcc-libs>=4.1.1
+ depends = gdk-pixbuf2
+ depends = glib2>=2.12.0
+ depends = glibc>=2.3.6
+ depends = gtk2>=2.8.0
+ depends = hicolor-icon-theme
+ depends = libx11
+ depends = libxcursor
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxinerama
+ depends = libxrandr
+ depends = libxrender
+ depends = pango
+ source = nerolinux-4.0.0.0b-x86_64.rpm::http://nero-mirror.com/support/NeroLINUX/nerolinux-4.0.0.0b-x86_64.rpm
+ md5sums = f5b307c37e5623231e0a042ee43e018c
pkgname = nerolinux4
diff --git a/PKGBUILD b/PKGBUILD
index ed2b05c7d16f..740b1370ca22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,59 @@
+# Original Maintainer: Nero AG <techsupport@nero.com>
# Maintainer: BethHarmon <BethOliviaHarmon at gmail dot com>
# Created from https://aur.archlinux.org/packages/nerolinux3
+# Edited by visious
pkgname=nerolinux4
pkgver=4.0.0.0b
-pkgrel=2
-pkgdesc="Nero Burning ROM for linux (legacy version)"
-url="http://www.nero.com"
-license=('custom')
-depends_i686=('gtk2' 'pangox-compat')
-depends_x86_64=('lib32-gtk2' 'lib32-pangox-compat')
-conflicts=('nerolinux')
-provides=('nerolinux')
-arch=('i686' 'x86_64')
-source=("nerolinux-${pkgver}-x86.rpm"::'http://nero-mirror.com/support/NeroLINUX/nerolinux-4.0.0.0b-x86.rpm')
-md5sums=('f49f49c588729c2afdbecb546d9b6041')
-install=nerolinux.install
+pkgrel=3
+pkgdesc="Nero Burning ROM for linux"
+arch=('x86_64')
+url="http://nerolinux.nero.com"
+license=('Nero AG')
+depends=(
+ 'atk'
+ 'cairo'
+ 'desktop-file-utils'
+ 'fontconfig'
+ 'gcc-libs>=4.1.1'
+ 'gdk-pixbuf2'
+ 'glib2>=2.12.0'
+ 'glibc>=2.3.6'
+ 'gtk2>=2.8.0'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'libxcursor'
+ 'libxext'
+ 'libxfixes'
+ 'libxi'
+ 'libxinerama'
+ 'libxrandr'
+ 'libxrender'
+ 'pango'
+)
+source=("nerolinux-${pkgver}-x86_64.rpm"::'http://nero-mirror.com/support/NeroLINUX/nerolinux-4.0.0.0b-x86_64.rpm')
+md5sums=('f5b307c37e5623231e0a042ee43e018c')
prepare() {
- cd "$srcdir"
- chmod a+rx -R *
- find . -type f -exec chmod -x \{\} \;
- chmod +x usr/bin/{nero,nerocmd}
+ cd "$srcdir"
+ chmod a+rx -R *
+ find . -type f -exec chmod -x \{\} \;
+ chmod +x usr/bin/{nero,nerocmd,neroexpress}
+
+ # Remove shortcut nerolinux-4.0.0.0b-x86_64.rpm
+ rm -r "${srcdir}/nerolinux-4.0.0.0b-x86_64.rpm"
+
+ # Fixing device problems
+ # Load module "sg" for Nerolinux.
+ mkdir -p "${srcdir}/etc/modules-load.d/"
+ touch "${srcdir}/etc/modules-load.d/${pkgname}.conf"
+ echo sg > "${srcdir}/etc/modules-load.d/${pkgname}.conf"
}
package() {
- cd "$pkgdir"
- mv "${srcdir}"/* .
- mkdir -p usr/share/licenses/nerolinux
- mv usr/share/doc/nero/EULA* usr/share/licenses/nerolinux
+ cd "$pkgdir"
+ mv "${srcdir}"/* .
+ mkdir -p usr/share/licenses/nerolinux
+ mv usr/share/doc/nero/EULA* usr/share/licenses/nerolinux
+ mv usr/lib64/ usr/lib/
}
diff --git a/nerolinux.install b/nerolinux.install
deleted file mode 100644
index b422c73fdb2b..000000000000
--- a/nerolinux.install
+++ /dev/null
@@ -1,24 +0,0 @@
-# arg 1: the new package version
-post_install() {
- echo "For Nero to be able to detect CD/DVD drives,"
- echo "add yourself to the 'optical' group."
- echo "Also make sure sg module is loaded."
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- echo "For Nero to be able to detect CD/DVD drives,"
- echo "add yourself to the 'optical' group."
- echo "Also make sure sg module is loaded."
-}
-
-# arg 1: the old package version
-pre_remove() {
- /bin/true
-}
-
-op=$1
-shift
-
-$op $*