summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprg3182016-08-23 17:06:01 -0400
committerprg3182016-08-23 17:06:01 -0400
commit623eacbdcf6f3e27d2a933c42652a238222d9bb5 (patch)
tree596496ec7307209ea56821606fdb2d4a256b2f47
downloadaur-623eacbdcf6f3e27d2a933c42652a238222d9bb5.tar.gz
initial commmit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ba311b4e95b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Aug 23 21:05:55 UTC 2016
+pkgbase = nesasm-git
+ pkgdesc = Linux port of the NESASM3 assembler.
+ pkgver = 4.b7affbb
+ pkgrel = 1
+ url = https://github.com/toastynerd/nesasm
+ arch = x86
+ arch = x86_64
+ license = Unknown
+ options = !emptydirs
+ source = nesasm::git+https://github.com/toastynerd/nesasm
+ md5sums = SKIP
+
+pkgname = nesasm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb4dfca438cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
+# Contributor: Lukas Sabota <LTsmooth42 _at_ gmail _dot_ com>
+pkgname=nesasm-git
+_pkgname=nesasm
+pkgver=4.b7affbb
+pkgrel=1
+pkgdesc="Linux port of the NESASM3 assembler."
+arch=('x86' 'x86_64')
+url="https://github.com/toastynerd/nesasm"
+license=('Unknown')
+groups=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=(${_pkgname}::git+https://github.com/toastynerd/nesasm)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make
+
+ mkdir -p $pkgdir/usr/bin
+ cp bin/nesasm $pkgdir/usr/bin
+}
+
+# vim:set ts=2 sw=2 et: