summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprcastro2016-01-07 14:14:08 -0200
committerprcastro2016-01-07 14:14:08 -0200
commit23a8f53cf20cdf60fbac49dc732f1fca54b255a2 (patch)
tree6bb26a821e5acfb60ffd24466faf0d1e67a86e0c
downloadaur-23a8f53cf20cdf60fbac49dc732f1fca54b255a2.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5a51b08dc31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Jan 7 16:13:01 UTC 2016
+pkgbase = nest
+ pkgdesc = Simulator for spiking neural network models
+ pkgver = 2.10.0
+ pkgrel = 1
+ url = www.nest-simulator.org/
+ arch = x86_64
+ license = GPL
+ depends = gsl
+ depends = libtool
+ depends = python
+ optdepends = ipython
+ optdepends = python-numpy
+ optdepends = python-scipy
+ optdepends = python-matplotlib
+ source = https://github.com/nest/nest-simulator/releases/download/v2.10.0/nest-2.10.0.tar.gz
+ md5sums = e97371d8b802818c4a7de35276470c0c
+
+pkgname = nest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cfead02a013
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Paulo Castro <p.oliveira.castro@gmail.com>
+pkgname=nest
+pkgver=2.10.0
+pkgrel=1
+pkgdesc="Simulator for spiking neural network models"
+arch=('x86_64')
+url="www.nest-simulator.org/"
+license=('GPL')
+depends=('gsl' 'libtool' 'python')
+optdepends=('ipython' 'python-numpy' 'python-scipy' 'python-matplotlib')
+source=("https://github.com/nest/nest-simulator/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('e97371d8b802818c4a7de35276470c0c')
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}