summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-10-31 20:04:43 -0400
committerAndrew Sun2018-10-31 20:04:43 -0400
commite16c8ceb4573652423f78d0f3268b4b0dde76787 (patch)
treef235c2dfb3823c72fa458d8ed851be92b56c75f7
parent3540587b93d17a141000b6fd4c87bacf98bd2285 (diff)
downloadaur-e16c8ceb4573652423f78d0f3268b4b0dde76787.tar.gz
nest: update to 2.16.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD37
2 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08e59a8d29d4..4ebf748d6164 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nest
pkgdesc = Simulator for spiking neural network models
- pkgver = 2.14.0
+ pkgver = 2.16.0
pkgrel = 1
url = http://www.nest-simulator.org/
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = nest
optdepends = python-numpy
optdepends = python-scipy
optdepends = python-matplotlib
- source = nest-2.14.0.tar.gz::https://github.com/nest/nest-simulator/archive/v2.14.0.tar.gz
- md5sums = a214b61da740c9252f3dfea5ed804441
+ source = nest-2.16.0.tar.gz::https://github.com/nest/nest-simulator/archive/v2.16.0.tar.gz
+ sha256sums = abfeb61719dec54da9477be035bef1d9d764f4e7663f63f6a6d9211f967e0490
pkgname = nest
diff --git a/PKGBUILD b/PKGBUILD
index 15fee4b6ac94..7835c506e98d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
# Contributor: Paulo Castro <p.oliveira.castro@gmail.com>
pkgname=nest
-pkgver=2.14.0
+pkgver=2.16.0
pkgrel=1
pkgdesc="Simulator for spiking neural network models"
arch=('x86_64')
@@ -10,32 +11,28 @@ license=('GPL')
depends=('gsl' 'libtool' 'python')
makedepends=('cmake' 'cython')
optdepends=('ipython' 'python-numpy' 'python-scipy' 'python-matplotlib')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/nest/nest-simulator/archive/v${pkgver}.tar.gz)
-md5sums=('a214b61da740c9252f3dfea5ed804441')
-
-
-prepare() {
- mkdir -p build
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nest/nest-simulator/archive/v${pkgver}.tar.gz")
+sha256sums=('abfeb61719dec54da9477be035bef1d9d764f4e7663f63f6a6d9211f967e0490')
build() {
- cd build
- cmake ../$pkgname-simulator-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -Dwith-gsl=ON \
- -Dwith-readline=ON \
- -Dwith-ltdl=ON \
- -Dwith-python=3
- make
+ mkdir -p "${srcdir}/build" && cd "${srcdir}/build"
+ cmake "${srcdir}/${pkgname}-simulator-${pkgver}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -Dwith-gsl=ON \
+ -Dwith-readline=ON \
+ -Dwith-ltdl=ON \
+ -Dwith-python=3
+ make
}
# Tests fail if no nest can be found in /usr/bin/
#check() {
-# cd build
-# make -k check
+# cd "${srcdir}/build"
+# make -k check
#}
package() {
- cd build
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
}