summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2020-04-07 22:07:47 +0200
committerCarsten Teibes2020-04-07 22:07:47 +0200
commit81400ce01fa06103ca5f803f0fa357aefb2e1604 (patch)
tree001e2766840d865bc86cbce1d97461f21b289517
parent82923bae661880b0ed39e9ca12fcf69b502bb3b5 (diff)
downloadaur-81400ce01fa06103ca5f803f0fa357aefb2e1604.tar.gz
[upd] 1.49→1.50
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd6d971a2f41..a52f66a24d5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nestopia
pkgdesc = An NES emulator featuring cycle exact emulation, a ridiculous number of mappers, and lots of custom sound chips.
- pkgver = 1.49
+ pkgver = 1.50
pkgrel = 1
url = http://0ldsk00l.ca/nestopia/
arch = x86_64
@@ -8,14 +8,12 @@ pkgbase = nestopia
makedepends = unzip
makedepends = mesa
makedepends = xdg-utils
- makedepends = git
makedepends = autoconf-archive
depends = sdl2
depends = gtk3
depends = libarchive
- depends = libao
- source = git+https://github.com/rdanbrook/nestopia.git#tag=1.49
- sha256sums = SKIP
+ source = nestopia-1.50.tar.gz::https://github.com/0ldsk00l/nestopia/archive/1.50.tar.gz
+ sha256sums = f0274f8b033852007c67237897c69725b811c0df8a6d0120f39c23e990662aae
pkgname = nestopia
diff --git a/PKGBUILD b/PKGBUILD
index bed37a2011ec..357f5d01ea57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
-# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
-# Maintainer: aimileus < me at aimileus dot nl >
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: aimileus < me at aimileus dot nl >
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Tiago Pierezan Camargo <tcamargo@gmail.com>
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=nestopia
-pkgver=1.49
+pkgver=1.50
pkgrel=1
pkgdesc='An NES emulator featuring cycle exact emulation, a ridiculous number of mappers, and lots of custom sound chips.'
url='http://0ldsk00l.ca/nestopia/'
license=('GPL')
arch=('x86_64')
-depends=('sdl2' 'gtk3' 'libarchive' 'libao')
-makedepends=('unzip' 'mesa' 'xdg-utils' 'git' 'autoconf-archive')
-source=("git+https://github.com/rdanbrook/nestopia.git#tag=$pkgver")
-sha256sums=('SKIP')
+depends=('sdl2' 'gtk3' 'libarchive')
+makedepends=('unzip' 'mesa' 'xdg-utils' 'autoconf-archive')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/0ldsk00l/nestopia/archive/$pkgver.tar.gz")
+sha256sums=('f0274f8b033852007c67237897c69725b811c0df8a6d0120f39c23e990662aae')
build() {
- cd "$pkgname"
- autoreconf -vif
- ./configure --prefix=/usr
+ cd $pkgname-$pkgver
+
+ autoreconf -fi
+ ./configure --prefix=/usr --enable-gui
make
}
package() {
- cd "$pkgname"
- make install DESTDIR="$pkgdir"
+ make -C $pkgname-$pkgver install DESTDIR="$pkgdir"
}