summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbobi2018-10-22 11:45:40 +0200
committerbobi2018-10-22 11:45:40 +0200
commit369d1f2ba3bae3f3507824c8677041d84a22425d (patch)
treef9cf1481a8c68f19e0974827f9eac2aa1bf0123a
downloadaur-369d1f2ba3bae3f3507824c8677041d84a22425d.tar.gz
PKGBUILD gathered from last commit of community/netbeans for version 8.2
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD58
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81daa98e1bce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = netbeans8
+ pkgdesc = IDE for Java, HTML5, PHP, Groovy, C and C++
+ pkgver = 8.2
+ pkgrel = 1
+ url = http://netbeans.org/
+ arch = any
+ license = CDDL
+ makedepends = gendesk
+ makedepends = setconf
+ depends = java-environment
+ depends = ttf-font
+ depends = libxtst
+ depends = giflib
+ depends = atk
+ optdepends = php: for developing programs in php
+ optdepends = groovy: for developing programs in groovy
+ optdepends = lib32-glibc
+ conflicts = netbeans
+ options = !strip
+ backup = usr/share/netbeans/etc/netbeans.conf
+ source = http://download.netbeans.org/netbeans/8.2/final/zip/netbeans-8.2-201609300101.zip
+ source = https://cdn.rawgit.com/ComFreek/chocolatey-packages/779f5c96f817ed1fa0d76fd90841873dc6c0ba74/icons/netbeans.png
+ sha256sums = ad9888334b9a6c1f1138dcb2eccc8ce4921463e871e46def4ecc617538160948
+ sha256sums = 048112cc3be78f41bf6eca8f664f3e92e97fc68df904ce87a7e0156a18d80c7e
+
+pkgname = netbeans8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10bc6a78d242
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: bobi <alexandre.garnier.86 at gmail dot com>
+# Contributor: Alexander F Rødseth <xyproto at archlinux dot org>
+# Contributor: Timm Preetz <timm at preetz dot us>
+# Contributor: Daniel J Griffiths <ghost1227 at archlinux dot us>
+# Contributor: Ben Wolsieffer <benwolsieffer at gmail dot com>
+
+_pkgname=netbeans
+pkgname=netbeans8
+pkgver=8.2
+# Get the subver from https://netbeans.org/downloads/zip.html
+_subver=201609300101
+pkgrel=1
+pkgdesc='IDE for Java, HTML5, PHP, Groovy, C and C++'
+conflicts=('netbeans')
+arch=('any')
+url='http://netbeans.org/'
+license=('CDDL')
+# classpath is not needed, see FS#38567 (Oracle JDK does not need atk either)
+depends=('java-environment' 'ttf-font' 'libxtst' 'giflib' 'atk')
+backup=('usr/share/netbeans/etc/netbeans.conf')
+makedepends=('gendesk' 'setconf')
+optdepends=('php: for developing programs in php'
+ 'groovy: for developing programs in groovy'
+ 'lib32-glibc')
+options=('!strip')
+# http://dlc-cdn.sun.com/netbeans/8.1/final/zip/
+source=("http://download.netbeans.org/netbeans/$pkgver/final/zip/netbeans-$pkgver-$_subver.zip"
+ 'https://cdn.rawgit.com/ComFreek/chocolatey-packages/779f5c96f817ed1fa0d76fd90841873dc6c0ba74/icons/netbeans.png')
+sha256sums=('ad9888334b9a6c1f1138dcb2eccc8ce4921463e871e46def4ecc617538160948'
+ '048112cc3be78f41bf6eca8f664f3e92e97fc68df904ce87a7e0156a18d80c7e')
+
+prepare() {
+ gendesk -f -n --pkgname "$_pkgname" --pkgdesc "$pkgdesc" \
+ --custom "StartupWMClass=NetBeans IDE $pkgver" --name "NetBeans" \
+ --exec 'netbeans %f' --startupnotify true
+ setconf "$_pkgname/bin/$_pkgname" basedir "/usr/share/$_pkgname"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/"{bin,share/applications}
+
+ # Binary file
+ install -Dm755 "$_pkgname/bin/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+
+ # Resources
+ cp -r "$_pkgname" "$pkgdir/usr/share/"
+
+ # Desktop shortcut and icon
+ install -Dm644 "$_pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 "$_pkgname.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+
+ # Cleanup of directory that contains the binary file and .exe-files
+ rm -r "$pkgdir/usr/share/$_pkgname/bin"
+}
+
+# getver: netbeans.org
+# vim:set ts=2 sw=2 et: