summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJun Bo Bi2019-02-14 21:09:57 -0500
committerJun Bo Bi2019-02-14 21:09:57 -0500
commit17be12b2d74aaebe4fff3e0b5b5169c5c5f1054f (patch)
tree61bfb91a9b419dc54a0a6585d70a6af8f23b3a5d
downloadaur-17be12b2d74aaebe4fff3e0b5b5169c5c5f1054f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84969cb061fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = netcoredbg
+ pkgdesc = Adds communication between KDE and your smartphone
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/Samsung/netcoredbg
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = dotnet-host
+ depends = dotnet-runtime
+ depends = dotnet-sdk
+ source = https://github.com/Samsung/netcoredbg/archive/latest.tar.gz
+ sha256sums = SKIP
+
+pkgname = netcoredbg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2637f73e64a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jun Bo Bi <jambonmcyeah@gmail.com>
+
+pkgname=netcoredbg
+pkgver=latest
+pkgrel=1
+pkgdesc='Adds communication between KDE and your smartphone'
+url='https://github.com/Samsung/netcoredbg'
+license=(MIT)
+arch=(x86_64)
+depends=(dotnet-host dotnet-runtime dotnet-sdk)
+makedepends=(git)
+optdepends=()
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ CC=clang CXX=clang++ \
+ cmake ../netcoredbg-$pkgver \
+ -DDOTNET_DIR=/opt/dotnet \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTING=OFF \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}