summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaughan Milliman2023-12-11 02:10:15 -0600
committerVaughan Milliman2023-12-11 02:10:15 -0600
commit5f6fc669e14f1c7ea2247a8d98cf831b481c74c8 (patch)
treec7473d71657cb8e65681e8347aa06941c21fe325
parent1ed6427135197eff62f2d289c36209840aafe074 (diff)
downloadaur-5f6fc669e14f1c7ea2247a8d98cf831b481c74c8.tar.gz
fixed package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9fe99667d05..0118fc7401fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = netcoredbg
pkgdesc = Debugger for .NET Core runtime
- pkgver = 2.2.3_992
+ pkgver = 3.0.0_1012
pkgrel = 1
url = https://github.com/Samsung/netcoredbg
arch = x86_64
@@ -8,10 +8,10 @@ pkgbase = netcoredbg
makedepends = git
makedepends = cmake
makedepends = clang
- makedepends = dotnet-sdk>=3.1
- depends = dotnet-host>=3.1
- depends = dotnet-runtime>=3.1
- source = netcoredbg-2.2.3-992.tar.gz::https://github.com/Samsung/netcoredbg/archive/refs/tags/2.2.3-992.tar.gz
- sha256sums = 353ad37177d332f74e569d2c24b17113d826f07073611693cf1670af212ed2df
+ makedepends = dotnet-sdk>=7
+ depends = dotnet-host>=7
+ depends = dotnet-runtime>=7
+ source = netcoredbg-3.0.0-1012.tar.gz::https://github.com/Samsung/netcoredbg/archive/refs/tags/3.0.0-1012.tar.gz
+ sha256sums = 54438b2f094bee5170e6cdeb45319988686c8c7f954ae36b8fe76045e5a0fd68
pkgname = netcoredbg
diff --git a/PKGBUILD b/PKGBUILD
index e5790cf3f357..df0baa796961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
-# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
+# Maintainer: Vaughan <vaughanm1@protonmail.com>
+# Former maintainer: tytan652 <tytan652 at tytanium dot xyz>
# Contributor: Jun Bo Bi <jambonmcyeah@gmail.com>
pkgname=netcoredbg
-_ver=2.2.3-992
-pkgver=${_ver//-/_}
+_pkgver="3.0.0-1012"
+pkgver="${_pkgver//-/_}"
pkgrel=1
pkgdesc='Debugger for .NET Core runtime'
url='https://github.com/Samsung/netcoredbg'
license=("MIT")
arch=("x86_64")
-depends=("dotnet-host>=3.1" "dotnet-runtime>=3.1")
-makedepends=("git" "cmake" "clang" "dotnet-sdk>=3.1")
+depends=("dotnet-host>=7" "dotnet-runtime>=7")
+makedepends=("git" "cmake" "clang" "dotnet-sdk>=7")
optdepends=()
-source=("$pkgname-$_ver.tar.gz::https://github.com/Samsung/netcoredbg/archive/refs/tags/$_ver.tar.gz")
-sha256sums=("353ad37177d332f74e569d2c24b17113d826f07073611693cf1670af212ed2df")
+source=("$pkgname-$_pkgver.tar.gz::https://github.com/Samsung/netcoredbg/archive/refs/tags/$_pkgver.tar.gz")
+sha256sums=("54438b2f094bee5170e6cdeb45319988686c8c7f954ae36b8fe76045e5a0fd68")
build() {
- cd "$pkgname-$_ver"
+ cd "$pkgname-$_pkgver"
+ # patch needed for some file (https://github.com/Samsung/netcoredbg/issues/147)
+ sed -i "20 a #include <cstdint>" src/interfaces/types.h
+
mkdir -p build; cd build
export CC=clang
@@ -30,7 +34,7 @@ build() {
}
package() {
- cd "$pkgname-$_ver"
+ cd "$pkgname-$_pkgver"
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
cd build