summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Wölfing2019-03-14 15:07:26 +0100
committerMax Wölfing2019-03-14 15:07:26 +0100
commit8fc013005a569369f62c7fc7c7c60337d5a66a73 (patch)
tree298e9dabd5ff34ec6afe10fe2bdf05d985328f5a
parent7393d625994b467c47c209d604f3adf2370a1026 (diff)
downloadaur-8fc013005a569369f62c7fc7c7c60337d5a66a73.tar.gz
Documentation in the example connection profile updated
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--mobile_mm2
-rw-r--r--mobile_mm.profile33
4 files changed, 26 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1aca17d841b..3bcceaf2c255 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = netctl-mm
pkgdesc = Mobile broadband support for netctl using ModemManager
- pkgver = 0.0.7
+ pkgver = 0.0.8
pkgrel = 1
arch = any
license = GPL
@@ -8,8 +8,8 @@ pkgbase = netctl-mm
depends = modemmanager
source = mobile_mm.profile
source = mobile_mm
- md5sums = ccad269de8f7c0d0cb89d3112849023d
- md5sums = 340792cd0b9f6f7452bbd96ca45a41a4
+ md5sums = 7b317a1f78ad63bfb8fb4973309883f5
+ md5sums = 5f2102d6c6e58b15a056d4e1800c8a92
pkgname = netctl-mm
diff --git a/PKGBUILD b/PKGBUILD
index 8365c7140597..d76d75467634 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Max Wölfing <ff0x@infr.cat>
pkgname=netctl-mm
-pkgver=0.0.7
+pkgver=0.0.8
pkgrel=1
pkgdesc="Mobile broadband support for netctl using ModemManager"
arch=(any)
license=('GPL')
depends=(netctl modemmanager)
source=(mobile_mm.profile mobile_mm)
-md5sums=('ccad269de8f7c0d0cb89d3112849023d'
- '340792cd0b9f6f7452bbd96ca45a41a4')
+md5sums=('7b317a1f78ad63bfb8fb4973309883f5'
+ '5f2102d6c6e58b15a056d4e1800c8a92')
package() {
install -Dm644 "$srcdir/mobile_mm.profile" "$pkgdir/etc/netctl/examples/mobile_mm"
diff --git a/mobile_mm b/mobile_mm
index d30de6c8ed03..35a08241cd6f 100644
--- a/mobile_mm
+++ b/mobile_mm
@@ -1,5 +1,5 @@
# Contributed by Max Wölfing <ff0x@infr.cat>
-# Version: 0.0.7
+# Version: 0.0.8
# KNOWN BUGS:
# - After suspend/hibernate the mobile broadband connection is not going to reconnect automatically (that's probably ok)
diff --git a/mobile_mm.profile b/mobile_mm.profile
index 9054e7d4700b..9d17077351cf 100644
--- a/mobile_mm.profile
+++ b/mobile_mm.profile
@@ -1,43 +1,48 @@
-Description='Example MM/MBIM mobile connection'
-Interface=wwp0s20u4
+Description='Example of a mobile broadband connection profile'
Connection=mobile_mm
+# The Wireless WAN interface provided by the modem
+Interface=wwp0s20u4
+
# Block/unblock your radio
#RFKill=tpacpi_wwan_sw
-# Currently only 'dhcp' or 'no' supported
+# IPv6 currently only supports 'dhcp' (default: no)
#IP6=no
-# Use default route provided by the peer (default: true)
+# Use the default route provided by the peer (default: true)
#DefaultRoute=false
+
# Use DNS provided by the peer (default: true)
#UsePeerDNS=true
-# Alternative, set your nameservers using the option below
+# As an alternative you can, set your nameservers using the option below
#DNS=('1.1.1.1' '2606:4700:4700::1111')
-# The user and password are not always required
+# Providing user and password are not always required
#User='example@yourprovider.com'
#Password='very secret'
-# The access point name you are connecting to
+# Access point you are connecting to
AccessPointName=apn
-# If your device has a PIN code, set it here.
+# If your device has a PIN code, set it here
#Pin=
-# If your device is PUK-locked, we will try to unlock it.
+
+# You can also add your PIN2/PUK code.
+# If your device is PUK-locked, we will try to unlock it
#Puk=
-#The number to dial. Defaults to '*99#'
+#The number to dial (default: *99#)
#PhoneNumber=*99***1#
# Enable/Disable roaming (default: no)
#Roaming=yes
-# Amount of seconds, we will wait until initialisation of modem will be interrupted, defaults to 5s
+# Amount of seconds, we will wait until initialisation of the modem will be interrupted (default: 5)
#TimeoutModem=10
-# Amount of seconds, we will wait for the connetion is established, defaults to 60s
-#TimeoutConnect=120
+# Amount of seconds, we will wait for the connection is established (default: 30)
+#TimeoutConnect=60
-# Mode can be one of (ANY, 2G, 3G, 4G). Defaults to 4G.
+# Preferred mode can be one of {ANY, 2G, 3G, 4G} (default: 4G)
#Mode=4G