summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephanie Wilde-Hobbs2021-03-22 18:55:04 +0000
committerStephanie Wilde-Hobbs2021-03-22 18:55:04 +0000
commit5b528fe96461609426270aebdbbf217b70b29208 (patch)
treeb038a6233d57faa4648c08c5b56ce53346a4975d
parent8c4fec53fa40fb50b71101904556eeecc8100ed3 (diff)
downloadaur-5b528fe96461609426270aebdbbf217b70b29208.tar.gz
Fix netdata submodules
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 33 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fb343b54c0b..8f14572b7a6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = netdata-git
pkgdesc = Real-time performance monitoring, in the greatest possible detail, over the web
- pkgver = v1.17.0.r31.g0af353168
+ pkgver = v1.29.3.r187.gbbcfd952f
pkgrel = 1
- url = https://github.com/firehol/netdata/wiki
+ url = https://github.com/netdata/netdata/wiki
install = netdata.install
arch = x86_64
license = GPL
@@ -10,9 +10,11 @@ pkgbase = netdata-git
depends = libmnl
depends = libnetfilter_acct
depends = zlib
+ depends = lz4
depends = judy
depends = libuv
depends = openssl
+ depends = json-c
optdepends = nodejs: for monitoring named and SNMP devices
optdepends = lm_sensors: for monitoring hardware sensors
optdepends = iproute2: for monitoring Linux QoS
@@ -24,10 +26,16 @@ pkgbase = netdata-git
optdepends = iw: for monitoring Linux as access point
provides = netdata
conflicts = netdata
- source = netdata::git+https://github.com/firehol/netdata
+ source = netdata::git+https://github.com/netdata/netdata
+ source = submodule-mqtt_websockets::git+https://github.com/underhood/mqtt_websockets.git
+ source = submodule-MQTT-C::git+https://github.com/underhood/MQTT-C.git
+ source = submodule-c-rbuf::git+https://github.com/underhood/c-rbuf.git
source = netdata.tmpfiles
source = netdata.sysusers
sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = 3f934ddd1f5248f9e11c29050c023d60b76e4098ec9c8d413bb362d43e9242f767fd58310d966076e8400779af8bda2459afcc314b267fcb9f1c84173e14e313
sha512sums = a910809a823ba58ca7bdaa72e8d68427b48f452c1fbb2343fa182ecb0a091a7640e73af24b8ba2fdd90e00aed8ef53b7fccd25cb8f04ca9b9fa6c8e52223ca66
diff --git a/.gitignore b/.gitignore
index 77e5c6d7eb9e..e9e7a88fc20e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
/pkg/
/src/
/netdata/
-/netdata-git-*.pkg.* \ No newline at end of file
+/netdata-git-*.pkg.*
+/submodule-mqtt_websockets/
+/submodule-MQTT-C/
+/submodule-c-rbuf/
diff --git a/PKGBUILD b/PKGBUILD
index 3b1e30f1c749..27d5e457843d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=netdata-git
_gitname=netdata
-pkgver=v1.17.0.r31.g0af353168
+pkgver=v1.29.3.r187.gbbcfd952f
pkgrel=1
pkgdesc="Real-time performance monitoring, in the greatest possible detail, over the web"
url="https://github.com/netdata/netdata/wiki"
@@ -21,16 +21,32 @@ optdepends=('nodejs: for monitoring named and SNMP devices'
'hddtemp: for monitoring hhd temperature'
'apcupsd: for monitoring APC UPS'
'iw: for monitoring Linux as access point')
-source=("$_gitname::git+https://github.com/firehol/netdata"
+source=("$_gitname::git+https://github.com/netdata/netdata"
+ "submodule-mqtt_websockets::git+https://github.com/underhood/mqtt_websockets.git"
+ "submodule-MQTT-C::git+https://github.com/underhood/MQTT-C.git"
+ "submodule-c-rbuf::git+https://github.com/underhood/c-rbuf.git"
"${_gitname}.tmpfiles"
"${_gitname}.sysusers")
sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'3f934ddd1f5248f9e11c29050c023d60b76e4098ec9c8d413bb362d43e9242f767fd58310d966076e8400779af8bda2459afcc314b267fcb9f1c84173e14e313'
'a910809a823ba58ca7bdaa72e8d68427b48f452c1fbb2343fa182ecb0a091a7640e73af24b8ba2fdd90e00aed8ef53b7fccd25cb8f04ca9b9fa6c8e52223ca66')
provides=('netdata')
conflicts=('netdata')
install="$_gitname.install"
+prepare() {
+ cd "$_gitname"
+ git submodule set-url mqtt_websockets "$srcdir"/submodule-mqtt_websockets
+ git submodule update --init --no-fetch mqtt_websockets
+
+ git -C mqtt_websockets submodule set-url MQTT-C "$srcdir"/submodule-MQTT-C
+ git -C mqtt_websockets submodule set-url c-rbuf "$srcdir"/submodule-c-rbuf
+ git -C mqtt_websockets submodule update --init --no-fetch MQTT-C c-rbuf
+}
+
pkgver() {
cd "$_gitname"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'