aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbigeagle2016-05-26 21:08:08 +0800
committerbigeagle2016-05-26 21:08:08 +0800
commita281775012ab6d2257bac98e50f3fe59947fb198 (patch)
tree5c7963755d92d310bd783a8b7eae566c4e28f6ab
parentd8a8db2d53432b368186378b2e5ecb8478e0d116 (diff)
downloadaur-a281775012ab6d2257bac98e50f3fe59947fb198.tar.gz
removed openssl hack
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 2 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8e8bbbf6c8a..37019feb2d64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = netease-cloud-music
pkgdesc = Netease Cloud Music, converted from .deb package
pkgver = 0.9.0_2
- pkgrel = 4
+ pkgrel = 5
url = http://music.163.com/
arch = x86_64
license = custom
@@ -18,12 +18,10 @@ pkgbase = netease-cloud-music
noextract = libssl1.0.0_1.0.2g-1ubuntu4.1_amd64.deb
noextract = libcue1_1.4.0-1_amd64.deb
source = http://s1.music.126.net/download/pc/netease-cloud-music_0.9.0-2_amd64.deb
- source = http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.0.0_1.0.2g-1ubuntu4.1_amd64.deb
source = http://archive.ubuntu.com/ubuntu/pool/universe/libc/libcue/libcue1_1.4.0-1_amd64.deb
source = https://music.163.com/html/web2/service.html
source = netease-cloud-music
md5sums = 24c44fe5e71e69cd7ac252c2ce611270
- md5sums = 0542b3182cef57f91f0c1dd3e03e6995
md5sums = 51920df6edb60d9ef5e4e9f3ae3be0d6
md5sums = 2f06d90c7b3362a01c287ec7b6a40f27
md5sums = 31a25ac517facc48762a6a9378a66f58
diff --git a/PKGBUILD b/PKGBUILD
index beab740d4341..92a221a7d880 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Justin Wong <justin.w.xd at gmail dot com>
pkgname=netease-cloud-music
pkgver=0.9.0_2
-pkgrel=4
+pkgrel=5
pkgdesc="Netease Cloud Music, converted from .deb package"
arch=("x86_64")
url="http://music.163.com/"
@@ -14,7 +14,6 @@ depends=(
)
source=(
"http://s1.music.126.net/download/pc/${pkgname}_${pkgver/_/-}_amd64.deb"
- "http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.0.0_1.0.2g-1ubuntu4.1_amd64.deb"
"http://archive.ubuntu.com/ubuntu/pool/universe/libc/libcue/libcue1_1.4.0-1_amd64.deb"
"https://music.163.com/html/web2/service.html"
"netease-cloud-music"
@@ -24,7 +23,6 @@ noextract=(
"libcue1_1.4.0-1_amd64.deb"
)
md5sums=('24c44fe5e71e69cd7ac252c2ce611270'
- '0542b3182cef57f91f0c1dd3e03e6995'
'51920df6edb60d9ef5e4e9f3ae3be0d6'
'2f06d90c7b3362a01c287ec7b6a40f27'
'31a25ac517facc48762a6a9378a66f58')
@@ -32,7 +30,6 @@ md5sums=('24c44fe5e71e69cd7ac252c2ce611270'
prepare() {
tar xf data.tar.xz
(mkdir -p libcue && cd libcue && ar xf ../libcue1_1.4.0-1_amd64.deb && tar xf data.tar.gz)
- (mkdir -p libssl && cd libssl && ar xf ../libssl1.0.0_1.0.2g-1ubuntu4.1_amd64.deb && tar xf data.tar.xz)
}
package() {
@@ -41,7 +38,5 @@ package() {
mkdir -p ${pkgdir}/usr/share/licenses/netease-cloud-music/
install -m644 service.html ${pkgdir}/usr/share/licenses/$pkgname/license.html
install -m755 libcue/usr/lib/libcue.so.1.0.4 ${pkgdir}/usr/lib/netease-cloud-music/libcue.so.1
- install -m755 libssl/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 ${pkgdir}/usr/lib/netease-cloud-music/libcrypto.so.1.0.0
- install -m755 libssl/lib/x86_64-linux-gnu/libssl.so.1.0.0 ${pkgdir}/usr/lib/netease-cloud-music/libssl.so.1.0.0
install -m755 netease-cloud-music ${pkgdir}/usr/bin/netease-cloud-music
}